summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen L Arnold <nerdboy@gentoo.org>2015-11-09 11:25:12 -0800
committerStephen L Arnold <nerdboy@gentoo.org>2015-11-09 11:50:52 -0800
commit622e0ff4ddd804d90540b660ac47f80783a01f9d (patch)
tree7005e35316d4599243330682dfba5b182217264e /app-editors/vim-qt/vim-qt-20150102-r1.ebuild
parentdev-haskell/hsql: drop old (diff)
downloadgentoo-622e0ff4ddd804d90540b660ac47f80783a01f9d.tar.gz
gentoo-622e0ff4ddd804d90540b660ac47f80783a01f9d.tar.bz2
gentoo-622e0ff4ddd804d90540b660ac47f80783a01f9d.zip
app-editors/vim-qt: minor config workaround for building with -flto
This affects all vim packages (braindead configure) but apps build and run fine with graphite and -flto. Package-Manager: portage-2.2.24
Diffstat (limited to 'app-editors/vim-qt/vim-qt-20150102-r1.ebuild')
-rw-r--r--app-editors/vim-qt/vim-qt-20150102-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-editors/vim-qt/vim-qt-20150102-r1.ebuild b/app-editors/vim-qt/vim-qt-20150102-r1.ebuild
index 4390d89d33df..a83941d94f44 100644
--- a/app-editors/vim-qt/vim-qt-20150102-r1.ebuild
+++ b/app-editors/vim-qt/vim-qt-20150102-r1.ebuild
@@ -26,7 +26,7 @@ fi
LICENSE="vim"
SLOT="0"
-IUSE="acl cscope debug lua luajit nls perl python racket ruby"
+IUSE="acl cscope debug lua luajit lto nls perl python racket ruby"
REQUIRED_USE="luajit? ( lua )
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -63,6 +63,11 @@ src_prepare() {
}
src_configure() {
+ if use lto ; then
+ LDFLAGS_OLD="$LDFLAGS"
+ local LDFLAGS="${LDFLAGS} -fno-lto -fno-use-linker-plugin"
+ fi
+
use debug && append-flags "-DDEBUG"
local myconf="--with-features=huge --disable-gpm --enable-multibyte"
@@ -95,6 +100,11 @@ src_configure() {
fi
econf ${myconf} --enable-gui=qt --with-vim-name=qvim --with-modified-by=Gentoo-${PVR}
+
+ if use lto ; then
+ LDFLAGS="${LDFLAGS_OLD}"
+ sed -i -e "s|-fno-lto -fno-use-linker-plugin||g" src/auto/config.mk
+ fi
}
src_install() {