summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-02 03:34:48 +0100
committerSam James <sam@gentoo.org>2022-06-02 03:36:30 +0100
commitb8d397054046a97dc868c05637b254956b4279cc (patch)
tree43aa1bf7390fecea38669bd9b9c401e710c5322e /app-editors/vile/vile-9.8t-r2.ebuild
parentapp-editors/xvile: add missing := dep on perl (diff)
downloadgentoo-b8d397054046a97dc868c05637b254956b4279cc.tar.gz
gentoo-b8d397054046a97dc868c05637b254956b4279cc.tar.bz2
gentoo-b8d397054046a97dc868c05637b254956b4279cc.zip
app-editors/vile: add missing := dep on perl
Bug: https://bugs.gentoo.org/848957 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vile/vile-9.8t-r2.ebuild')
-rw-r--r--app-editors/vile/vile-9.8t-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/vile/vile-9.8t-r2.ebuild b/app-editors/vile/vile-9.8t-r2.ebuild
new file mode 100644
index 000000000000..add73176aa2f
--- /dev/null
+++ b/app-editors/vile/vile-9.8t-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="ftp://ftp.invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2:0=
+ virtual/libcrypt:=
+ perl? ( dev-lang/perl:= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-eselect/eselect-vi"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_OPT_S="" install
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}