summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-10 13:42:44 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-10 14:07:48 -0400
commit7dd4612ae3a561bd0de703d87d33ec6dc804ec19 (patch)
tree848b31673b4753d16973e95871e2dad97e87ad71 /app-editors/neovim
parentnet-wireless/gr-iio: Add Python 3.10 support (diff)
downloadgentoo-7dd4612ae3a561bd0de703d87d33ec6dc804ec19.tar.gz
gentoo-7dd4612ae3a561bd0de703d87d33ec6dc804ec19.tar.bz2
gentoo-7dd4612ae3a561bd0de703d87d33ec6dc804ec19.zip
app-editors/neovim: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/Manifest3
-rw-r--r--app-editors/neovim/neovim-0.5.1.ebuild113
-rw-r--r--app-editors/neovim/neovim-0.6.0.ebuild118
-rw-r--r--app-editors/neovim/neovim-0.6.1-r1.ebuild120
4 files changed, 0 insertions, 354 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 2e1a0c842e8b..f09d190fc087 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,4 +1 @@
-DIST neovim-0.5.1.tar.gz 10349190 BLAKE2B eb7e0c6a0742369c4a0fbc32a0f0e5d595f03470fb10287c39dde2f86db433a21798acee49d2cc363f18843950ef76d1376f5e52358d0b19a4b1e090c0d620a6 SHA512 a5a976c4998e821e0d9a9038d3f0c9e7c424a951f6bfc6d75898916d6a004ac668f31a34c3472fc4fca6b1d9652ac662b06780dd04dc6a77ecdc81564ec05709
-DIST neovim-0.6.0.tar.gz 10592213 BLAKE2B f0f4654b6ae37b29c903ec54175b7dc6742c9f8dadd3242119a0288df4e3262ff5d9cb7ccd41fd8b1431db828ddb806714ced62ef1893cb923cf84badd47e3d8 SHA512 c007d076fb89288fe0496fa243fc6f485b0b33120c96b0bf37d8fe6469c672eb641fefbc3f7262ec726e40910c44d37ff7efb1723c05ba920ff6ae512b1d43e6
-DIST neovim-0.6.1.tar.gz 10597584 BLAKE2B 3e2da61b768f5cae44e08f0ef7f386ce4b878b3248c9a7f7691f62dd732abfa59558467e190a5bcbb5f5007801b2003380296678fca42a0b46dde9a71ed496f4 SHA512 399489f6aaabec2a89b695b22dcd860149acaad723372cced0b4d2cdae464e2db5758372b9123cd0d2a683e0ea42b871935eb85e550cecce620d896691cfda53
DIST neovim-0.7.0.tar.gz 10925354 BLAKE2B 0524d008ba1ebbe823406e94cfb048014b26bc394c686b2dd84bb7fae5a1f7f3acd42764b03b6efec10c0f25045c5838f624542b5125947e5f42d3b0d2ad1f84 SHA512 3597c54fb925a4d607bca9ba0fdb37df90ecb816da99f52baf46cc2ec79727a55048ba1d8d22c8e7d61f0e8e35546326b1d0d15c0a91de8bf5bc529c45fb1ce0
diff --git a/app-editors/neovim/neovim-0.5.1.ebuild b/app-editors/neovim/neovim-0.5.1.ebuild
deleted file mode 100644
index 7256b3ebf29c..000000000000
--- a/app-editors/neovim/neovim-0.5.1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} luajit )
-
-inherit cmake lua-single optfeature xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility"
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~x64-macos"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+lto +nvimpager +tui"
-
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-# Upstream say the test library needs LuaJIT
-# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-#REQUIRED_USE="test? ( lua_single_target_luajit )"
-#RESTRICT="!test? ( test )"
-
-# Upstream build scripts invoke the Lua interpreter
-BDEPEND="${LUA_DEPS}
- dev-util/gperf
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
-"
-# TODO: add tests, dev-lua/busted has now got luajit support.
-# bug #584694
-DEPEND="${LUA_DEPS}
- dev-lua/luv[${LUA_SINGLE_USEDEP}]
- $(lua_gen_cond_dep '
- dev-lua/lpeg[${LUA_USEDEP}]
- dev-lua/mpack[${LUA_USEDEP}]
- ')
- $(lua_gen_cond_dep '
- dev-lua/LuaBitOp[${LUA_USEDEP}]
- ' lua5-{1,2})
- dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1.2
- dev-libs/msgpack:0=
- dev-libs/tree-sitter:=
- tui? (
- dev-libs/libtermkey
- >=dev-libs/unibilium-2.0.0:0=
- )
-"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-vi
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
-)
-
-src_prepare() {
- # use our system vim dir
- sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
- -i src/nvim/globals.h || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
- # TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
- local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
- -DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
- -DMIN_LOG_LEVEL=3
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
- optfeature "Python plugin support" dev-python/pynvim
- optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
- optfeature "remote/nvr support" dev-python/neovim-remote
-}
diff --git a/app-editors/neovim/neovim-0.6.0.ebuild b/app-editors/neovim/neovim-0.6.0.ebuild
deleted file mode 100644
index 54ffbbed750b..000000000000
--- a/app-editors/neovim/neovim-0.6.0.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} luajit )
-
-inherit cmake lua-single optfeature xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility"
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+lto +nvimpager test +tui"
-
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-# Upstream say the test library needs LuaJIT
-# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
-# TODO: Get tests running
-RESTRICT="!test? ( test ) test"
-
-# Upstream build scripts invoke the Lua interpreter
-BDEPEND="${LUA_DEPS}
- dev-util/gperf
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
-"
-DEPEND="${LUA_DEPS}
- dev-lua/luv[${LUA_SINGLE_USEDEP}]
- $(lua_gen_cond_dep '
- dev-lua/lpeg[${LUA_USEDEP}]
- dev-lua/mpack[${LUA_USEDEP}]
- ')
- $(lua_gen_cond_dep '
- dev-lua/LuaBitOp[${LUA_USEDEP}]
- ' lua5-{1,2})
- dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1.2
- dev-libs/msgpack:0=
- dev-libs/tree-sitter:=
- tui? (
- dev-libs/libtermkey
- >=dev-libs/unibilium-2.0.0:0=
- )
-"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-vi
-"
-BDEPEND="
- test? (
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
-)
-
-src_prepare() {
- # Use our system vim dir
- sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
- -i src/nvim/globals.h || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
- # TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
- local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
- -DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
- -DMIN_LOG_LEVEL=3
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
- optfeature "Python plugin support" dev-python/pynvim
- optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
- optfeature "remote/nvr support" dev-python/neovim-remote
-}
diff --git a/app-editors/neovim/neovim-0.6.1-r1.ebuild b/app-editors/neovim/neovim-0.6.1-r1.ebuild
deleted file mode 100644
index b3ea1f81894c..000000000000
--- a/app-editors/neovim/neovim-0.6.1-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} luajit )
-
-inherit cmake lua-single optfeature xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility"
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~x64-macos"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+lto +nvimpager test +tui"
-
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-# Upstream say the test library needs LuaJIT
-# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
-# TODO: Get tests running
-RESTRICT="!test? ( test ) test"
-
-# Upstream build scripts invoke the Lua interpreter
-BDEPEND="${LUA_DEPS}
- >=dev-util/gperf-3.1
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
-"
-# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
-# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
-DEPEND="${LUA_DEPS}
- >=dev-lua/luv-1.42.0[${LUA_SINGLE_USEDEP}]
- $(lua_gen_cond_dep '
- dev-lua/lpeg[${LUA_USEDEP}]
- dev-lua/mpack[${LUA_USEDEP}]
- ')
- $(lua_gen_cond_dep '
- dev-lua/LuaBitOp[${LUA_USEDEP}]
- ' lua5-{1,2})
- >=dev-libs/libuv-1.42.0:=
- >=dev-libs/libvterm-0.1.4
- >=dev-libs/msgpack-3.0.0:=
- >=dev-libs/tree-sitter-0.20.1:=
- tui? (
- >=dev-libs/libtermkey-0.22
- >=dev-libs/unibilium-2.0.0:0=
- )
-"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-vi
-"
-BDEPEND="
- test? (
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
-)
-
-src_prepare() {
- # Use our system vim dir
- sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
- -i src/nvim/globals.h || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
- # TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
- local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
- -DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
- -DMIN_LOG_LEVEL=3
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
- optfeature "Python plugin support" dev-python/pynvim
- optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
- optfeature "remote/nvr support" dev-python/neovim-remote
-}