summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-05 12:14:56 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-05 12:18:36 +0100
commit59a1111fe5abb99b375c14428c68c96a2828cc0b (patch)
tree0c2589be105ead430d5353de380ea03b6f30f1df /app-editors/neovim
parentdev-lua/lpeg: clean up old. (diff)
downloadgentoo-59a1111fe5abb99b375c14428c68c96a2828cc0b.tar.gz
gentoo-59a1111fe5abb99b375c14428c68c96a2828cc0b.tar.bz2
gentoo-59a1111fe5abb99b375c14428c68c96a2828cc0b.zip
app-editors/neovim: version bump.
Also add a missing dependency: dev-util/gperf. I took this opportunity to stabilise a lot of reverse dependencies needed to emerge neovim. They have been sitting in the tree for a while (> 6 months) so we're safe to fast stabilise them. Bug: https://bugs.gentoo.org/628258 Closes: https://bugs.gentoo.org/636940 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.2.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 53453fc4271d..5327f56c0180 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -7,3 +7,4 @@ DIST neovim-0.1.5.tar.gz 7813974 BLAKE2B 244633b131b86a15bee13abf003ee04d5c3243d
DIST neovim-0.1.6.tar.gz 7810818 BLAKE2B c36cd224d767687b07c187940033fcbabb00f4b0a2ed2fc1838aadbeeb5acbf0c729c42ab0f82029fa2dc10b997e69f3ec2e85a01500f11380160ad9202bbba8 SHA512 360d69bc11a3cb7b2c203adc7e76edad736b1a2fb7033d2d0c6444da168053ea0b621daf7978e9c158e14c5e04af8599005bf5eb800d9d1776007257b0e0e56f
DIST neovim-0.1.7.tar.gz 7601279 BLAKE2B 473665470740256fd9f555b3e85901f19a1800c68e2303f5fbf062bd5961f2735c6a836a48d6616e31c56ae97481d461e299bb358b7658ffea1a1b1b9c2147dd SHA512 f7dbac4b2090fbf9764585ebf147c529b655d6e30cca9404cd161e2bd78f3aaa2f714d86a8c3efd1935dc92363757c381833d0059043807db0bea3db2fc6d10c
DIST neovim-0.2.0.tar.gz 7846467 BLAKE2B ee929122b3855ccab6247a0e8ab975b09d77e1034229ea324ed82ad705cacbd39f55d2fa96eea3f3677c7efe64c69ebecedd5fde09e508a6fd23acb6a1f5b489 SHA512 fc4be03c5bee1c9928376938679f9a900f3ee2e58df817d1cb9b5af51350dccca63a7638114b0326ec4565a047faaa4b50fecfc932c1d59ee92efa54625e22cd
+DIST neovim-0.2.2.tar.gz 8325879 BLAKE2B dbf43c5927b8c8719adae9a3f73c57429de47f1b7c7489a118b7467df2f0d32cd02df8e10889727b4dd77fe8b4fb4f95520c678d6775d5d908705770a47cec0c SHA512 5609defe86ac98356f1b9ae9adc6049bb4df920a9a2ae3104f761d52d4dd54cbc84d2596231595dd9b0aa97201fef2121e6c5c86a19267ab6b871dbf4b568209
diff --git a/app-editors/neovim/neovim-0.2.2.ebuild b/app-editors/neovim/neovim-0.2.2.ebuild
new file mode 100644
index 000000000000..a37942870e06
--- /dev/null
+++ b/app-editors/neovim/neovim-0.2.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+clipboard +luajit +nvimpager python ruby +tui +jemalloc"
+
+CDEPEND=">=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-1.0.0
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? (
+ dev-lang/lua:=
+ dev-lua/LuaBitOp
+ )
+ tui? (
+ >=dev-libs/libtermkey-0.19
+ >=dev-libs/unibilium-1.1.1
+ )
+ dev-libs/libvterm
+ dev-lua/lpeg[luajit=]
+ dev-lua/mpack[luajit=]
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
+ virtual/libiconv
+ virtual/libintl"
+
+RDEPEND="
+ ${CDEPEND}
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+ clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/globals.h || die
+
+ # add eclass to bash filetypes
+ sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFEAT_TUI=$(usex tui)
+ -DENABLE_JEMALLOC=$(usex jemalloc)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}