summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 18:29:34 +0100
committerSam James <sam@gentoo.org>2023-10-04 18:43:00 +0100
commitd69aefd0db5222a02fad47fd40ce106c4cf13ccf (patch)
tree29646a84deb85b4146f46845b6366efc58b3f1bb /app-editors/ne
parentnet-misc/openssh: add 9.5_p1 (diff)
downloadgentoo-d69aefd0db5222a02fad47fd40ce106c4cf13ccf.tar.gz
gentoo-d69aefd0db5222a02fad47fd40ce106c4cf13ccf.tar.bz2
gentoo-d69aefd0db5222a02fad47fd40ce106c4cf13ccf.zip
app-editors/ne: don't redefine _FORTIFY_SOURCE
Closes: https://bugs.gentoo.org/892958 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/ne')
-rw-r--r--app-editors/ne/Manifest1
-rw-r--r--app-editors/ne/ne-3.3.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-editors/ne/Manifest b/app-editors/ne/Manifest
index 6b735d790750..3fdacc2f64f0 100644
--- a/app-editors/ne/Manifest
+++ b/app-editors/ne/Manifest
@@ -1 +1,2 @@
DIST ne-3.3.1.tar.gz 1138072 BLAKE2B 8494ff955b456bbac2e82823ee155980f8fab5a1071d0bfd6a987f1ed0724129ab2ecb70737547836b592369b45daf5e499d50d7230b04c5eabfd1536a56271f SHA512 d8c1d8cd9bbafcc7c8c485ca4454d6979be3d33ae918139865ce5f76e428f165043707c95c2e440bd9bccd00c67ce81a41f87f94b85cae3518c4749233718123
+DIST ne-3.3.2.tar.gz 1154326 BLAKE2B 8c11abac9a960a41de2faed9b2e948cca9ca7f8345757796fb7daa112e62d565096b1cd3a4ca2e76cfb1616ee8c0dad01bb2fe5306bac6f0aadca0644b91eb6d SHA512 6c4fabb0ecade31322d5f96203f3bba3316264d8f98a46188796ce88f4b7fd17af8569832ae2638770f8ceb59138b0395b0e03817db961bfe94c917fa390ebf3
diff --git a/app-editors/ne/ne-3.3.2.ebuild b/app-editors/ne/ne-3.3.2.ebuild
new file mode 100644
index 000000000000..4743055eb679
--- /dev/null
+++ b/app-editors/ne/ne-3.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( doc/html/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.1-respect-CFLAGS.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/-O3//' \
+ -e 's/-Wp,-D_FORTIFY_SOURCE=2//' \
+ src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}/syntax
+ doins syntax/*.jsf
+
+ doman doc/${PN}.1
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}