summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-22 11:30:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-22 11:53:52 +0100
commit890adca6eccc4fca4f25be16c2c04da1011c3979 (patch)
treef73fc673b3e4a7e28423242edb80a872d83c8389 /app-editors/juffed
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.207,4.9.207,4.14.1... (diff)
downloadgentoo-890adca6eccc4fca4f25be16c2c04da1011c3979.tar.gz
gentoo-890adca6eccc4fca4f25be16c2c04da1011c3979.tar.bz2
gentoo-890adca6eccc4fca4f25be16c2c04da1011c3979.zip
app-editors/juffed: Fix build with QScintilla-2.10.3
Closes: https://bugs.gentoo.org/652928 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/juffed')
-rw-r--r--app-editors/juffed/files/juffed-0.10_p20160323-qscintilla-2.10.3.patch71
-rw-r--r--app-editors/juffed/juffed-0.10_p20160323-r1.ebuild3
2 files changed, 73 insertions, 1 deletions
diff --git a/app-editors/juffed/files/juffed-0.10_p20160323-qscintilla-2.10.3.patch b/app-editors/juffed/files/juffed-0.10_p20160323-qscintilla-2.10.3.patch
new file mode 100644
index 000000000000..f4a22957480d
--- /dev/null
+++ b/app-editors/juffed/files/juffed-0.10_p20160323-qscintilla-2.10.3.patch
@@ -0,0 +1,71 @@
+From 49b6982336ad127b2b780d2ae7c1be1104d9dae5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 10 Apr 2018 20:31:38 +0200
+Subject: [PATCH] Fix build with QScintilla-2.10.3
+
+---
+ src/app/qsci/lexers/qscilexerada.h | 3 ---
+ src/app/qsci/lexers/qscilexerhaskell.h | 3 ---
+ src/app/qsci/lexers/qscilexerlisp.h | 3 ---
+ src/app/qsci/lexers/qscilexernsis.h | 3 ---
+ 4 files changed, 12 deletions(-)
+
+diff --git a/src/app/qsci/lexers/qscilexerada.h b/src/app/qsci/lexers/qscilexerada.h
+index 984f97e..30c6646 100644
+--- a/src/app/qsci/lexers/qscilexerada.h
++++ b/src/app/qsci/lexers/qscilexerada.h
+@@ -3,9 +3,6 @@
+
+ #include <Qsci/qscilexer.h>
+
+-// located in SciLexer.h
+-#define SCLEX_ADA 20
+-
+ #define SCE_ADA_DEFAULT 0
+ #define SCE_ADA_WORD 1
+ #define SCE_ADA_IDENTIFIER 2
+diff --git a/src/app/qsci/lexers/qscilexerhaskell.h b/src/app/qsci/lexers/qscilexerhaskell.h
+index 78c8978..56a3614 100644
+--- a/src/app/qsci/lexers/qscilexerhaskell.h
++++ b/src/app/qsci/lexers/qscilexerhaskell.h
+@@ -3,9 +3,6 @@
+
+ #include <Qsci/qscilexer.h>
+
+-// located in SciLexer.h
+-#define SCLEX_HASKELL 68
+-
+ #define SCE_HA_DEFAULT 0
+ #define SCE_HA_IDENTIFIER 1
+ #define SCE_HA_KEYWORD 2
+diff --git a/src/app/qsci/lexers/qscilexerlisp.h b/src/app/qsci/lexers/qscilexerlisp.h
+index 5b43d74..6e5dc32 100644
+--- a/src/app/qsci/lexers/qscilexerlisp.h
++++ b/src/app/qsci/lexers/qscilexerlisp.h
+@@ -3,9 +3,6 @@
+
+ #include <Qsci/qscilexer.h>
+
+-// located in SciLexer.h
+-#define SCLEX_LISP 21
+-
+ #define SCE_LISP_DEFAULT 0
+ #define SCE_LISP_COMMENT 1
+ #define SCE_LISP_NUMBER 2
+diff --git a/src/app/qsci/lexers/qscilexernsis.h b/src/app/qsci/lexers/qscilexernsis.h
+index 8b009ec..06efc40 100644
+--- a/src/app/qsci/lexers/qscilexernsis.h
++++ b/src/app/qsci/lexers/qscilexernsis.h
+@@ -3,9 +3,6 @@
+
+ #include <Qsci/qscilexer.h>
+
+-// located in SciLexer.h
+-#define SCLEX_NSIS 43
+-
+ #define SCE_NSIS_DEFAULT 0
+ #define SCE_NSIS_COMMENT 1
+ #define SCE_NSIS_STRINGDQ 2
+--
+2.17.0
+
diff --git a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
index 97e18f2d896c..1c1f52f7c75b 100644
--- a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
+++ b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,7 @@ DOCS=( ChangeLog README )
PATCHES=(
"${FILESDIR}/${P}-qscintilla-2.10.patch"
"${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-qscintilla-2.10.3.patch"
)
src_prepare() {