summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-24 23:20:25 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-24 23:24:31 -0400
commitd9508ebdedae86b7f6b9d5155f7d9aa2459ee32b (patch)
tree640cdd88385b983ea90ae82d204571d227089138 /app-editors/gvim/gvim-9999.ebuild
parentapp-editors/vim: version bump (diff)
downloadgentoo-d9508ebdedae86b7f6b9d5155f7d9aa2459ee32b.tar.gz
gentoo-d9508ebdedae86b7f6b9d5155f7d9aa2459ee32b.tar.bz2
gentoo-d9508ebdedae86b7f6b9d5155f7d9aa2459ee32b.zip
app-editors/gvim: version bump
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index f14e66e27dfb..505f21966df8 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -8,15 +8,13 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE=threads
inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-r1
-MY_PV=${PV//./-}
-
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vim/vim.git"
- EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${MY_PV}
+ EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
else
- SRC_URI="https://github.com/vim/vim/archive/v${MY_PV}.tar.gz -> vim-${PV}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.542-gentoo-patches.tar.bz2"
+ SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
+ https://dev.gentoo.org/~radhermit/vim/vim-7.4.827-gentoo-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
fi
@@ -77,7 +75,7 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
"
-S=${WORKDIR}/vim-${MY_PV}
+S=${WORKDIR}/vim-${PV}
pkg_setup() {
# people with broken alphabets run into trouble. bug 82186.