summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-04 02:32:11 +0100
committerSam James <sam@gentoo.org>2024-10-04 02:32:11 +0100
commitd7a3bddd21e2bcda4f0d37ae06284c07e5a4cf54 (patch)
tree1d921eaba26c33cd533c277e235dfba4139492af /app-doc
parentdev-util/libtree: fix build on arches w/o -m32/-m64 (diff)
downloadgentoo-d7a3bddd21e2bcda4f0d37ae06284c07e5a4cf54.tar.gz
gentoo-d7a3bddd21e2bcda4f0d37ae06284c07e5a4cf54.tar.bz2
gentoo-d7a3bddd21e2bcda4f0d37ae06284c07e5a4cf54.zip
app-doc/gnu-c-intro-ref: add 0_pre20240831
Closes: https://bugs.gentoo.org/911528 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gnu-c-intro-ref/Manifest1
-rw-r--r--app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20240831.ebuild46
-rw-r--r--app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild5
3 files changed, 50 insertions, 2 deletions
diff --git a/app-doc/gnu-c-intro-ref/Manifest b/app-doc/gnu-c-intro-ref/Manifest
index b47e753099d6..3be4c23e89c3 100644
--- a/app-doc/gnu-c-intro-ref/Manifest
+++ b/app-doc/gnu-c-intro-ref/Manifest
@@ -1 +1,2 @@
DIST c-intro-and-ref-36a1041cfa542b8c00aa6daad2624797164d87f4.tar.gz 195859 BLAKE2B d2a6b32e1f19c88c947e3a98825cdf6eec8192a6e79b4eb9b47bbb69368e2dcb8bb6a6e77dbf05070b918aead7d60d72dd9afcd719a7c1f8d51793fe2ababaa0 SHA512 bd4bd01a24a941c7272d0e9e88867a1669779e390f50725c883bd18cd578899529d2179c919a0a4db386bcb59d3e485a3487b762ee499ee4585e9c579b802787
+DIST c-intro-and-ref-62962013107481127176ef04d69826e41f51313c.tar.gz 322484 BLAKE2B bfd6f613965e5fe62494d245e05b2fdcd9d40ad2a08b81f93e7264735811a0aabd04e6ca0cba140e5e5c2989ec77ef60cfb13ac63c060d76ad0d6e4e9ca0221b SHA512 8ee1f11b47e938cff6d7e93cccf388043643c97f095fa91200c5aae78ef765eb7cd9fbb7d5d77df9dbe13bf5e9694c876f9283f5cde8070f7df8eaabf9c0e40c
diff --git a/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20240831.ebuild b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20240831.ebuild
new file mode 100644
index 000000000000..7324680b8e48
--- /dev/null
+++ b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20240831.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU C Language Intro and Reference Manual"
+HOMEPAGE="https://savannah.gnu.org/projects/c-intro-and-ref/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/c-intro-and-ref.git"
+ inherit git-r3
+else
+ MY_COMMIT="62962013107481127176ef04d69826e41f51313c"
+ SRC_URI="https://git.savannah.nongnu.org/cgit/c-intro-and-ref.git/snapshot/c-intro-and-ref-${MY_COMMIT}.tar.gz"
+ S="${WORKDIR}"/c-intro-and-ref-${MY_COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="FDL-1.3+"
+SLOT="0"
+IUSE="pdf"
+
+BDEPEND="
+ sys-apps/texinfo
+ pdf? (
+ app-text/ghostscript-gpl
+ app-text/texlive-core
+ virtual/texi2dvi
+ )
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_compile() {
+ emake info html $(usev pdf 'pdf')
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-info install-html $(usev pdf 'install-pdf')
+}
diff --git a/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild
index 206a80678ffc..7324680b8e48 100644
--- a/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild
+++ b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/git/c-intro-and-ref.git"
inherit git-r3
else
- MY_COMMIT="36a1041cfa542b8c00aa6daad2624797164d87f4"
+ MY_COMMIT="62962013107481127176ef04d69826e41f51313c"
SRC_URI="https://git.savannah.nongnu.org/cgit/c-intro-and-ref.git/snapshot/c-intro-and-ref-${MY_COMMIT}.tar.gz"
S="${WORKDIR}"/c-intro-and-ref-${MY_COMMIT}
KEYWORDS="~amd64"
@@ -27,6 +27,7 @@ BDEPEND="
pdf? (
app-text/ghostscript-gpl
app-text/texlive-core
+ virtual/texi2dvi
)
"