summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/podbrowser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/podbrowser')
-rw-r--r--app-doc/podbrowser/Manifest1
-rw-r--r--app-doc/podbrowser/files/Makefile.new32
-rw-r--r--app-doc/podbrowser/files/missing_icon.patch32
-rw-r--r--app-doc/podbrowser/metadata.xml5
-rw-r--r--app-doc/podbrowser/podbrowser-0.12-r3.ebuild47
5 files changed, 117 insertions, 0 deletions
diff --git a/app-doc/podbrowser/Manifest b/app-doc/podbrowser/Manifest
new file mode 100644
index 000000000000..bf3cc9874237
--- /dev/null
+++ b/app-doc/podbrowser/Manifest
@@ -0,0 +1 @@
+DIST podbrowser-0.12.tar.gz 81394 SHA256 d49df6479305c6ef5d17c6973a0d5efee9353771457a4ebc510dd48f2af607f5 SHA512 ff6a734f2df8bb0913c9030fd103490e59178bc672ac1c152eb9a0c2aece82c293615cbfcc7cf99dcfe2c448bdc35d2c6fdcb9b106e958d3ffb62b2eb9372c77 WHIRLPOOL 5c0eeb6f892359da569d386a7ad0e2d442581fad9defc1d05ddbd32581565dcaf3f0ffe5110f2317c2b199fb9018d3c6d4507c3fc48d22996843526fbff4e7cb
diff --git a/app-doc/podbrowser/files/Makefile.new b/app-doc/podbrowser/files/Makefile.new
new file mode 100644
index 000000000000..250bbf8780df
--- /dev/null
+++ b/app-doc/podbrowser/files/Makefile.new
@@ -0,0 +1,32 @@
+# $Id$
+NAME=podbrowser
+PREFIX=/usr/local
+BINDIR=$(PREFIX)/bin
+DATADIR=$(PREFIX)/share
+ICONDIR=$(DATADIR)/icons/hicolor/48x48/apps
+MANDIR=$(DATADIR)/man/man1
+DESTDIR=
+
+all: podbrowser
+
+podbrowser:
+ @mkdir -p build
+
+ perl -ne 's!\@PREFIX\@!$(PREFIX)!g ; s!\@LIBDIR\@!$(LIBDIR)!g ; print' < $(NAME).pl > build/$(NAME)
+ pod2man $(NAME).pl | gzip -c > build/$(NAME).1.gz
+
+install:
+ mkdir -p $(DESTDIR)/$(BINDIR) \
+ $(DESTDIR)/$(DATADIR)/$(NAME) \
+ $(DESTDIR)/$(DATADIR)/applications \
+ $(DESTDIR)/$(ICONDIR) \
+ $(DESTDIR)/$(MANDIR)
+ install -m 0644 $(NAME).glade $(DESTDIR)/$(DATADIR)/$(NAME)/
+ install -m 0644 $(NAME).png $(DESTDIR)/$(ICONDIR)/
+ install -m 0644 $(NAME).desktop $(DESTDIR)/$(DATADIR)/applications/
+ install -m 0644 build/$(NAME).1.gz $(DESTDIR)/$(MANDIR)/
+ install -m 0755 build/$(NAME) $(DESTDIR)/$(BINDIR)/$(NAME)
+ install -m 0755 html2ps-$(NAME) $(DESTDIR)/$(BINDIR)/html2ps-$(NAME)
+
+clean:
+ rm -rf build
diff --git a/app-doc/podbrowser/files/missing_icon.patch b/app-doc/podbrowser/files/missing_icon.patch
new file mode 100644
index 000000000000..55ec1223bf24
--- /dev/null
+++ b/app-doc/podbrowser/files/missing_icon.patch
@@ -0,0 +1,32 @@
+X-Description: Provide alternative icons if those expected not in current theme
+X-Author: Jeffrey Ratcliffe <Jeffrey.Ratcliffe@gmail.com>
+X-Bugs-Gentoo: https://bugs.gentoo.org/319573
+
+--- podbrowser-0.12/podbrowser.pl
++++ podbrowser-0.12/podbrowser.pl
+@@ -60,9 +60,22 @@
+ my $APP = Gtk2::GladeXML->new($GLADE_FILE);
+ my $THEME = get_an_icon_theme();
+ my $TIPS = Gtk2::Tooltips->new;
+-my $IDX_PBF = Gtk2::Gdk::Pixbuf->new_from_file($THEME->lookup_icon('stock_bookmark', 16, 'force-svg')->get_filename)->scale_simple(16, 16, 'bilinear');
+-my $PAGE_PBF = Gtk2::Gdk::Pixbuf->new_from_file($THEME->lookup_icon('stock_new-text', 16, 'force-svg')->get_filename)->scale_simple(16, 16, 'bilinear');
+-my $FOLDER_PBF = Gtk2::Gdk::Pixbuf->new_from_file($THEME->lookup_icon('gnome-fs-directory', 16, 'force-svg')->get_filename)->scale_simple(16, 16, 'bilinear');
++my ( $IDX_PBF, $PAGE_PBF, $FOLDER_PBF );
++if ($THEME->lookup_icon('stock_bookmark', 16, 'force-svg')) {
++ $IDX_PBF = Gtk2::Gdk::Pixbuf->new_from_file($THEME->lookup_icon('stock_bookmark', 16, 'force-svg')->get_filename)->scale_simple(16, 16, 'bilinear');
++} else {
++ $IDX_PBF = Gtk2::Image->new->render_icon( 'gtk-index', 'menu' );
++}
++if ($THEME->lookup_icon('stock_new-text', 16, 'force-svg')) {
++ $PAGE_PBF = Gtk2::Gdk::Pixbuf->new_from_file($THEME->lookup_icon('stock_new-text', 16, 'force-svg')->get_filename)->scale_simple(16, 16, 'bilinear');
++} else {
++ $PAGE_PBF = Gtk2::Image->new->render_icon( 'gtk-new', 'menu' );
++}
++if ($THEME->lookup_icon('gnome-fs-directory', 16, 'force-svg')) {
++ $FOLDER_PBF = Gtk2::Gdk::Pixbuf->new_from_file($THEME->lookup_icon('gnome-fs-directory', 16, 'force-svg')->get_filename)->scale_simple(16, 16, 'bilinear');
++} else {
++ $FOLDER_PBF = Gtk2::Image->new->render_icon( 'gtk-directory', 'menu' );
++}
+ my $NORMAL_CURSOR = Gtk2::Gdk::Cursor->new('left_ptr');
+ my $BUSY_CURSOR = Gtk2::Gdk::Cursor->new('watch');
+ my $ITEMS = {};
diff --git a/app-doc/podbrowser/metadata.xml b/app-doc/podbrowser/metadata.xml
new file mode 100644
index 000000000000..708bcbd30056
--- /dev/null
+++ b/app-doc/podbrowser/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>perl</herd>
+</pkgmetadata>
diff --git a/app-doc/podbrowser/podbrowser-0.12-r3.ebuild b/app-doc/podbrowser/podbrowser-0.12-r3.ebuild
new file mode 100644
index 000000000000..792586cc8045
--- /dev/null
+++ b/app-doc/podbrowser/podbrowser-0.12-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="PodBrowser is a documentation browser for Perl"
+HOMEPAGE="http://jodrell.net/projects/podbrowser"
+SRC_URI="http://jodrell.net/files/podbrowser/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+SRC_TEST="do"
+
+RDEPEND="dev-perl/gtk2-gladexml
+ dev-perl/gtk2-perl
+ dev-perl/HTML-Parser
+ dev-perl/Locale-gettext
+ virtual/perl-Pod-Simple
+ dev-perl/URI
+ dev-perl/Gtk2-Ex-PodViewer
+ dev-perl/Gtk2-Ex-PrintDialog
+ dev-perl/Gtk2-Ex-Simple-List
+ || ( >=dev-lang/perl-5.16 <dev-lang/perl-5.16[-build] )
+ >=x11-libs/gtk+-2.6.0:2
+ >=x11-themes/gnome-icon-theme-2.10.0
+ >=gnome-base/libglade-2:2.0"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/missing_icon.patch
+ cp "${FILESDIR}"/Makefile.new "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake DESTDIR="${D}" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}