summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 16:02:43 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 16:27:07 +0100
commit71a73b5e3655713587d9068f3b7846ecc130e014 (patch)
tree121883b60862d323ea63e6f7e849c1ce65c6d80d /app-dicts
parentapp-crypt/seahorse: Drop old (diff)
downloadgentoo-71a73b5e3655713587d9068f3b7846ecc130e014.tar.gz
gentoo-71a73b5e3655713587d9068f3b7846ecc130e014.tar.bz2
gentoo-71a73b5e3655713587d9068f3b7846ecc130e014.zip
app-dicts/gnome-dictionary: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gnome-dictionary/Manifest1
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.18.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index a19f62b30724..d0a855b33643 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1,2 +1,3 @@
DIST gnome-dictionary-3.14.2.tar.xz 827932 SHA256 2f2a0293c5de83f624cead84d7bb3f93d30a30554640926bb2db9c4944840f82 SHA512 4042207acf9d17dad0736b16811584b42f5c3fb9219e1bf591292c67c5a4272f4238b0ec178adc40b4dd02313ba0ff3b751b65ae64e8d73c67f90dd8079fb68b WHIRLPOOL e50878b529e6827047ed5daf30157218907b6ff69383d1183df257a8bfdc39fd14e81b2199899b36ff97a0a1d08716834d2496d8111d4a0aface5c93b4266c89
DIST gnome-dictionary-3.16.2.tar.xz 847024 SHA256 a2981a76ecf57a5e5f1ebc88697f228a40e550c3371535aa15cc959fe51badd5 SHA512 f6c50a8d10e360320ac2ed34a56723f9e7eb72f81f27d40bc69a63eab23cad31e7ff45fb6712ff14b84b3ec2f82ae35bfab0ddde7980766b77d1416be67f384a WHIRLPOOL 6fe96815b79e1d217377ca61d74e2a61ab67a89057e3131cbbbb24b6c43fc908298cab4b34d3ab1c0700859deb18b7ed45d4870261fd0009118f168535157365
+DIST gnome-dictionary-3.18.0.tar.xz 852072 SHA256 5338962124f6d784920ed4968d98734a7589513b36e4f4a6ff00d1ed5afb4ead SHA512 ea276880329422e08923cc9346821bfd7c9bc1b71c09c6521a28f01a6bee34ec4be3b7f503ed8d37916a9b6351074ffd6d4333fed46d7c820198ebf0e62f5eb4 WHIRLPOOL 1c70faa84b96ddebafc2297ed6ea08ea3cec62a76340d5dc0800c2176603dec187b33f1a406538b832907196356f4015cf3c029868447998ef8e22f6f7cb0aef
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.18.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.18.0.ebuild
new file mode 100644
index 000000000000..148b84314a61
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.18.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0/9" # subslot = suffix of libgdict-1.0.so
+IUSE="+introspection ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39:2[dbus]
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable ipv6)
+}