summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-08-30 22:37:01 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-08-30 23:47:30 -0700
commitf3ff97d8781737a826ae4a62bdfa80194b094608 (patch)
tree302b3cc84c2168b25b7ff81b824e3d8bf6615e80 /app-crypt
parentx11-misc/polybar: optfeature for backlight udev rule (diff)
downloadgentoo-f3ff97d8781737a826ae4a62bdfa80194b094608.tar.gz
gentoo-f3ff97d8781737a826ae4a62bdfa80194b094608.tar.bz2
gentoo-f3ff97d8781737a826ae4a62bdfa80194b094608.zip
app-crypt/sbctl: add 0.15.4
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/sbctl/Manifest3
-rw-r--r--app-crypt/sbctl/sbctl-0.15.4.ebuild45
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/sbctl/Manifest b/app-crypt/sbctl/Manifest
index a96d507722c3..f5c9b71057cb 100644
--- a/app-crypt/sbctl/Manifest
+++ b/app-crypt/sbctl/Manifest
@@ -4,3 +4,6 @@ DIST sbctl-0.13.tar.gz.sig 566 BLAKE2B e0996fc4732501b1e66b7c65c9f4523a0c9f4b714
DIST sbctl-0.14-deps.tar.xz 114919252 BLAKE2B a2baa7cca501d924c1353404725999fb8372b52e88a3e2bd7760cf04da4900c676a326c3687adb58169acfb032e4009bb35be66cef3547cf888767325a0baecb SHA512 75122f835dc4f2bd41a8dbdd2b5ed6ad4c9c2f2f802f989245d08c55620d4eb992d23c78812bc761b96fb6b44b6eb6b6ae702b32d8b8f60ad23ac8a76f7e70bd
DIST sbctl-0.14.tar.gz 17809255 BLAKE2B a59eb3c5a32cb73cb2993c785d16798cbc83b70186eda8c8ce064a17fc338d3e70b93b277ad55c20991952e8d807c77f2a23ae4467c045019ba717ba342d5442 SHA512 a541324ec0b42503f5b5837b18e5f3076aa6fbe3c32041c3362945be52c281c6d057a856512cd134df37bf133106061af34d2b4fbfc377852ae4a86078e65fd8
DIST sbctl-0.14.tar.gz.sig 566 BLAKE2B a5ec700d7ebf42393114c7b193483218df285977622f8ca6c2fb50b622478889647083b34c008fe8618244232416b374f099dd0ca7fce0f961949ef8b9cddbd8 SHA512 8508cc4a77e8bd08d77b2119d59c65d8724ace4576e1d233d0801c0b470afaac96981915c86a185ad0a29e94b7ad6aae1c6c3d52574f353d75d20d11cd503b0f
+DIST sbctl-0.15.4-deps.tar.xz 123785076 BLAKE2B c54b60e89b4ea0bf6ce414198a74465b5e176a5a200f070e092fa536f81d48945a2c2ac88fdcaadfd4d7bc6511c32cbfe9e8c8a4c30c7ea8ea9947af9fdf9545 SHA512 7c5ca431e8832e576cef662d5ba806b4be07a23567d86f7b8e8cb16c57167aaeafe8bafa8875806db2ba7aced9979d5999b837dccd1d90ade60c029de244b242
+DIST sbctl-0.15.4.tar.gz 17822565 BLAKE2B a2c7f1c49ac3052a30af9245b015c730cdc0cc9d9bca011e52de967da5d733f0de0bee2da8ba28da00418553ce4d86cfd3859a5f029f44ae8cfec6f18da50102 SHA512 98278b816c14f61191d3aadeb7bcf22b5482315b36b201764ce88d3287420f488b7c9cb2cc1468800bfa2351cb0e8c8dbc32ecabbe4f6ab275f375859379fc03
+DIST sbctl-0.15.4.tar.gz.sig 566 BLAKE2B 678351ba31138e2b1bb90e2dbfe20f0af333b47c6f1cfb5caf5d473efa716d5ac00d407f858ab6510130430a0f54fc61edb8e261f2c11faa49763a97395850d5 SHA512 3cc14391c4d2446a64bd9f34b29816f05e1e2ff2db2c65228b536298bca0035eb991322264f03f5c68e7b488af0df09fb77276d942b265e43f831e5d9777fcfe
diff --git a/app-crypt/sbctl/sbctl-0.15.4.ebuild b/app-crypt/sbctl/sbctl-0.15.4.ebuild
new file mode 100644
index 000000000000..26ab1494e604
--- /dev/null
+++ b/app-crypt/sbctl/sbctl-0.15.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature verify-sig
+
+DESCRIPTION="Secure Boot key manager"
+HOMEPAGE="https://github.com/Foxboron/sbctl"
+SRC_URI="https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz.sig )"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/asciidoc
+ verify-sig? ( sec-keys/openpgp-keys-foxboron )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/foxboron.asc"
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sig}
+ fi
+
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+}
+
+pkg_postinst() {
+ optfeature "automatically signing installed kernels with sbctl keys on each kernel installation" \
+ "sys-kernel/installkernel[systemd]"
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "Newer versions of sbctl move configuration from"
+ elog "/usr/share/secureboot to /var/lib/sbctl. sbctl will emit a"
+ elog "warning to run 'sbctl setup --migrate' upon invocation"
+ elog "until the migration is performed."
+ fi
+}