summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-12-20 19:47:20 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2017-12-20 19:49:41 -0500
commit6b1d96cc8361a747f228519aa88963d92d08e456 (patch)
tree07e8477ed72a1ce932ac379e366b9620dbba089c /app-crypt
parentapp-crypt/yubikey-manager: bump to 0.5.0 (diff)
downloadgentoo-6b1d96cc8361a747f228519aa88963d92d08e456.tar.gz
gentoo-6b1d96cc8361a747f228519aa88963d92d08e456.tar.bz2
gentoo-6b1d96cc8361a747f228519aa88963d92d08e456.zip
app-crypt/yubikey-manager-qt: bump to 0.4.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest1
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.4.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index 37cdbbddcb2f..f373469b271f 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1 +1,2 @@
DIST yubikey-manager-qt-0.3.2.tar.gz 175662 BLAKE2B 149ff32d35ec642cbbebf1352ef8ec18c6e105658daf4831c251e01843c1fc852851eb3f40eb7fd7c85fe58c7243f9fa7a2eb0640189628d67898b1f1e987ae7 SHA512 5ae0b802f041a37a67bef6f7c8b5224fe47d145bcb3bef8c42e300048e849bbcf333de6d15a9a671ced21741d412af9419c08fd3b018276ce997b3cdd5ba55f5
+DIST yubikey-manager-qt-0.4.0.tar.gz 183566 BLAKE2B 2364d0d257ab5c05d0555aba4bb01ee1639a2c3a42b47173ae905945a6265b123985ad7d8fe50b0cfd38a1a0a588f3e1424aa46585ddbf50337ce2456899067e SHA512 12cef9636f06a92fdb3fce7cea5b97af3255b9cdd1b4feb4e184999eb77c17e465db927f56cd0e443a8ce8afc27b7e4be19ed07da7c41259f909ac4e98971de2
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.4.0.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.4.0.ebuild
new file mode 100644
index 000000000000..04d1dcd6ecb1
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit eutils qmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://github.com/Yubico/yubikey-manager-qt/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=app-crypt/yubikey-manager-0.5.0[${PYTHON_USEDEP}]
+ dev-python/pyotherside[${PYTHON_USEDEP}]
+ dev-qt/qtsingleapplication[qt5]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ rm -rf vendor ykman-gui/vendor || die
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/qtsingleapplication.pri/d" \
+ -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+ echo "${PV}" > VERSION || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+}