summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2023-04-11 18:07:26 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2023-04-11 18:25:44 +0200
commit18022b89f4dfa99ca61c1c57700d6e1dc4eadd5a (patch)
tree3c02b5cfe6c896d7af51a6d25379fda3751add8a /app-crypt
parentsys-apps/dbus: drop 1.15.2 (diff)
downloadgentoo-18022b89f4dfa99ca61c1c57700d6e1dc4eadd5a.tar.gz
gentoo-18022b89f4dfa99ca61c1c57700d6e1dc4eadd5a.tar.bz2
gentoo-18022b89f4dfa99ca61c1c57700d6e1dc4eadd5a.zip
app-crypt/yubihsm-connector: new package; add 3.0.4
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubihsm-connector/Manifest2
-rw-r--r--app-crypt/yubihsm-connector/metadata.xml11
-rw-r--r--app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-connector/Manifest b/app-crypt/yubihsm-connector/Manifest
new file mode 100644
index 000000000000..9ca150c24533
--- /dev/null
+++ b/app-crypt/yubihsm-connector/Manifest
@@ -0,0 +1,2 @@
+DIST yubihsm-connector-3.0.4-vendor.tar.xz 972044 BLAKE2B cae22a6a581689663460980ff12ab3055547967881e6cac68a65c43c33fbb76116b50b9646e7fdebebd8d68cdb2e506a1a99634c09bc4981554d3d8cd1b4d186 SHA512 accc9934c81321019e140c71e92e4382a1525c797df52243cf76be1f338e873ce0fac54439dbeb9acb5b57dd6a1dee8ab433d35d23ad5b0e53f5d8c490ad2bcc
+DIST yubihsm-connector-3.0.4.tar.gz 38522 BLAKE2B 51efcecfad9e4276f05ead81b1ce1646396f99b89046a14daaac4c1d41b6a88306934291070842507f616dc90ce9e61d0c99a424d7c4291fa3f2610cdb16f619 SHA512 cdd56bb95061e5e45ecbbc2f46b4e669d2b2faa57b2b9484646161fc332ab7f46fd4c3825d0e075397f39634fad94870a646ca8f93368197da7dd379f000abf0
diff --git a/app-crypt/yubihsm-connector/metadata.xml b/app-crypt/yubihsm-connector/metadata.xml
new file mode 100644
index 000000000000..2d2ca25e4c70
--- /dev/null
+++ b/app-crypt/yubihsm-connector/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubihsm-connector</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild b/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild
new file mode 100644
index 000000000000..2eb8fd785e8a
--- /dev/null
+++ b/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd udev
+
+DESCRIPTION="Server to expose YubiHSM 2 to network"
+HOMEPAGE="https://developers.yubico.com/yubihsm-connector/"
+SRC_URI="
+ https://developers.yubico.com/${PN}/Releases/${P}.tar.gz
+ https://dev.gentoo.org/~zx2c4/distfiles/${P}-vendor.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="
+ virtual/libusb:1
+ virtual/udev
+ acct-user/yubihsm-connector
+ acct-group/yubihsm-connector
+"
+BDEPEND=""
+
+src_compile() {
+ ego generate
+ ego build ${GOFLAGS}
+}
+
+src_install() {
+ dobin yubihsm-connector
+ systemd_dounit deb/yubihsm-connector.service
+ udev_dorules deb/70-yubihsm-connector.rules
+ insinto /etc
+ doins deb/yubihsm-connector.yaml
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}