summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-09-28 14:43:23 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-10-04 10:23:53 -0400
commit5ce37c8ef4f0c1429d3e1a423bd6a7c4897b38d0 (patch)
treecbac559b1c64ef6051586aef4617430139817bdc /app-crypt/tpm2-tools
parentsys-libs/llvm-libunwind: Fix the typo correctly (diff)
downloadgentoo-5ce37c8ef4f0c1429d3e1a423bd6a7c4897b38d0.tar.gz
gentoo-5ce37c8ef4f0c1429d3e1a423bd6a7c4897b38d0.tar.bz2
gentoo-5ce37c8ef4f0c1429d3e1a423bd6a7c4897b38d0.zip
app-crypt/tpm2-tools: Bump to 5.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tools')
-rw-r--r--app-crypt/tpm2-tools/Manifest1
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
index ec36aa46f00c..158898da959b 100644
--- a/app-crypt/tpm2-tools/Manifest
+++ b/app-crypt/tpm2-tools/Manifest
@@ -1,2 +1,3 @@
DIST tpm2-tools-4.3.2.tar.gz 887708 BLAKE2B ee6fe3d0566138d6289d1a91252ccb106d36ff80d55f2d6f9ee30c8e16338d706e80085ac5f4f56a79bcb339e5dcb240efcf71d4003bcffdad366f3cd7a1165b SHA512 1aa47c62c3d2a83195ec649e50c0be2c8be39f926806d8d7cb96edc499c385d527661813e02024e98f83ae9ebcb22d7dadc507ddfab48be9bbe428d9439d7ee1
DIST tpm2-tools-5.1.1.tar.gz 1044427 BLAKE2B 885ff61ad971c95d067bf8f9339de289f082f3103d1c382f45ac3ffbd4d5effc343ddc3c2c74b97b9d31f3f823d264991d1726c1f9c21d5c9b82ac1cdf714d3f SHA512 4e094dcffb66103773d85e866ab9ba8db5d0f205ff9658e08fe14e8e41250570a7f7274b4048934adf256ea41650fa498fc3d6da2786adc241a4bf2e8f7bf78e
+DIST tpm2-tools-5.2.tar.gz 1072078 BLAKE2B 27d035e0f44029db57477a1fd10e1cee9b470ad54411297985cb7f33ba7bbb7a94ac392815e32287d69abf928dce0c361703542b812ae88b208ddca645bb3be2 SHA512 9fb5dc298717a8a57c89d286e3590370a096c81b14d2d8d4eb5fca140d66148a8e24727ee04fb02057bbfcc3ede50e93ba0ef22396888c9df48bf6f42a5d6e6b
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.2.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.2.ebuild
new file mode 100644
index 000000000000..87c3b2f56979
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit autotools bash-completion-r1 python-single-r1
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/tpm2-tools/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fapi test"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-crypt/tpm2-tss-3.0.1[fapi?]
+ dev-libs/openssl:=
+ net-misc/curl
+ sys-libs/efivar:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? (
+ app-crypt/swtpm
+ app-crypt/tpm2-abrmd
+ dev-util/cmocka
+ )"
+BDEPEND="virtual/pkgconfig
+ sys-devel/autoconf-archive
+ test? (
+ app-editors/vim-core
+ dev-tcltk/expect
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
+ )
+ ${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.1.1-no-efivar-automagic.patch"
+)
+
+src_prepare() {
+ default
+ sed -i \
+ "s/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/" \
+ "configure.ac" || die
+ "./scripts/utils/man_to_bashcompletion.sh" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable fapi) \
+ $(use_enable test unit) \
+ --with-bashcompdir=$(get_bashcompdir) \
+ --enable-hardening
+}
+
+src_install() {
+ default
+ mv "${ED}"/$(get_bashcompdir)/tpm2{_completion.bash,} || die
+ local utils=( "${ED}"/usr/bin/tpm2_* )
+ bashcomp_alias tpm2 "${utils[@]##*/}"
+}