summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/pesign
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/pesign')
-rw-r--r--app-crypt/pesign/Manifest1
-rw-r--r--app-crypt/pesign/files/destdir.patch10
-rw-r--r--app-crypt/pesign/metadata.xml11
-rw-r--r--app-crypt/pesign/pesign-0.108.ebuild53
4 files changed, 75 insertions, 0 deletions
diff --git a/app-crypt/pesign/Manifest b/app-crypt/pesign/Manifest
new file mode 100644
index 000000000000..4d114926bda6
--- /dev/null
+++ b/app-crypt/pesign/Manifest
@@ -0,0 +1 @@
+DIST pesign-0.108.tar.gz 96838 SHA256 2019882be0286df1c58efa8c588332106b89418a6bd0fce3de8da4ca16636986 SHA512 f72fb9c3e843341300b68e06bb153690734f6e506cdd9f0d9362c760ff48194ed1ed29e0b58a5050e7331069ad47a9902cc9e34bf616667baf84208f2b69a918 WHIRLPOOL 0af005d0b6dbdff23787c009153cae07c6907d111f57831611e85c49656e29e150ffd71683f349880cfb8975547ea3a3e655cdce31b047b355ecf097e7c7ba77
diff --git a/app-crypt/pesign/files/destdir.patch b/app-crypt/pesign/files/destdir.patch
new file mode 100644
index 000000000000..70332410a3c8
--- /dev/null
+++ b/app-crypt/pesign/files/destdir.patch
@@ -0,0 +1,10 @@
+diff --git a/Make.defaults b/Make.defaults
+index 864f98b..e2c967b 100644
+--- a/Make.defaults
++++ b/Make.defaults
+@@ -1,4 +1,4 @@
+-INSTALLROOT:= /
++INSTALLROOT:= $(DESTDIR)
+ PREFIX := /usr
+
+ HOSTARCH = $(shell uname -m | sed s,i[3456789]86,ia32,)
diff --git a/app-crypt/pesign/metadata.xml b/app-crypt/pesign/metadata.xml
new file mode 100644
index 000000000000..3d054ecd92f9
--- /dev/null
+++ b/app-crypt/pesign/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gregkh@gentoo.org</email>
+ <description>do whatever</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vathpela/pesign</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/pesign/pesign-0.108.ebuild b/app-crypt/pesign/pesign-0.108.ebuild
new file mode 100644
index 000000000000..a17c46449a83
--- /dev/null
+++ b/app-crypt/pesign/pesign-0.108.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Tools for manipulating signed PE-COFF binaries"
+HOMEPAGE="https://github.com/vathpela/pesign"
+SRC_URI="https://github.com/vathpela/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/nspr
+ dev-libs/openssl:0
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ sys-boot/gnu-efi
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/destdir.patch
+}
+
+src_install() {
+ default
+
+ # remove some files that don't make sense for Gentoo installs
+ rm -rf "${ED}/etc/" "${ED}/usr/share/doc/pesign/" || die
+
+ # create .so symlink
+ ln -s libdpe.so "${ED}/usr/$(get_libdir)/libdpe.so.0"
+}
+#
+#src_prepare() {
+# local iarch
+# case ${ARCH} in
+# ia64) iarch=ia64 ;;
+# x86) iarch=ia32 ;;
+# amd64) iarch=x86_64 ;;
+# *) die "unsupported architecture: ${ARCH}" ;;
+# esac
+# sed -i "/^EFI_ARCH=/s:=.*:=${iarch}:" configure || die
+# sed -i 's/-m64$/& -march=x86-64/' tests/Makefile.in || die
+#}