summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-04-25 06:52:35 -0500
committerBen Kohler <bkohler@gentoo.org>2020-04-25 06:52:56 -0500
commit789d183ac5ed110b99b2c7f8c35cf1222df9fac3 (patch)
tree5673dcf32639bc1078c2b7097976ed690c332db5 /app-crypt/pdfcrack/pdfcrack-0.19.ebuild
parentnet-misc/dropbox: bump to 96.3.166 (diff)
downloadgentoo-789d183ac5ed110b99b2c7f8c35cf1222df9fac3.tar.gz
gentoo-789d183ac5ed110b99b2c7f8c35cf1222df9fac3.tar.bz2
gentoo-789d183ac5ed110b99b2c7f8c35cf1222df9fac3.zip
app-crypt/pdfcrack: bump to 0.19
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.19.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.19.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.19.ebuild b/app-crypt/pdfcrack/pdfcrack-0.19.ebuild
new file mode 100644
index 000000000000..9ccc4f961851
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.19.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14-cflags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}