summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-02-16 23:27:19 +0100
committerDavid Seifert <soap@gentoo.org>2022-02-16 23:27:19 +0100
commit9cc477ab7d6c6add0c4145d15d6b4676d42cd824 (patch)
treea9477774f13782528ff81cea860e58e7d43deb47 /app-crypt/nasty
parentdev-java/slf4j-simple: removed obsolete 1.7.30-r1 (diff)
downloadgentoo-9cc477ab7d6c6add0c4145d15d6b4676d42cd824.tar.gz
gentoo-9cc477ab7d6c6add0c4145d15d6b4676d42cd824.tar.bz2
gentoo-9cc477ab7d6c6add0c4145d15d6b4676d42cd824.zip
app-crypt/nasty: add subslot op on app-crypt/gpgme
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/nasty')
-rw-r--r--app-crypt/nasty/nasty-0.6-r2.ebuild (renamed from app-crypt/nasty/nasty-0.6-r1.ebuild)18
1 files changed, 7 insertions, 11 deletions
diff --git a/app-crypt/nasty/nasty-0.6-r1.ebuild b/app-crypt/nasty/nasty-0.6-r2.ebuild
index 574cd87cb1de..2596a2964bf5 100644
--- a/app-crypt/nasty/nasty-0.6-r1.ebuild
+++ b/app-crypt/nasty/nasty-0.6-r2.ebuild
@@ -1,32 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Proof-of-concept GPG passphrase recovery tool"
HOMEPAGE="http://www.vanheusden.com/nasty/"
SRC_URI="http://www.vanheusden.com/nasty/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="app-crypt/gpgme"
-DEPEND="${RDEPEND}"
-DOCS=(
- readme.txt
-)
+RDEPEND="app-crypt/gpgme:="
+DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}/${P}-flags.patch"
-)
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
src_compile() {
emake CC="$(tc-getCC)" DEBUG=
}
src_install() {
- einstalldocs
dobin nasty
+ dodoc readme.txt
}