summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-06-05 16:00:59 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-06-05 16:05:25 -0400
commit1a1fc80ba7e47494400019c924245aff51b8307e (patch)
treefc6a96e01e6393cc85f1d525d209f6b445e3a3d0 /app-crypt/libu2f-host
parentapp-office/skrooge: Drop 2.18.0 (diff)
downloadgentoo-1a1fc80ba7e47494400019c924245aff51b8307e.tar.gz
gentoo-1a1fc80ba7e47494400019c924245aff51b8307e.tar.bz2
gentoo-1a1fc80ba7e47494400019c924245aff51b8307e.zip
app-crypt/libu2f-host: bump to 1.1.10
Bug: https://bugs.gentoo.org/678580 Bug: https://bugs.gentoo.org/679724 Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/libu2f-host')
-rw-r--r--app-crypt/libu2f-host/Manifest1
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/libu2f-host/Manifest b/app-crypt/libu2f-host/Manifest
index 1fc68dbc77bb..f2179ea58d19 100644
--- a/app-crypt/libu2f-host/Manifest
+++ b/app-crypt/libu2f-host/Manifest
@@ -1,3 +1,4 @@
DIST libu2f-host-1.1.1.tar.xz 455652 BLAKE2B f5cc4dd7752d66790b4139e5b8e9262f6622b9608bc8b220640db773ce1e794b58eb3fdf855df4e73417aabf5f8e979218dfd1b068111c66c6d830ef4b7ebb97 SHA512 1f6d26d47cabd44391a780f03d88b6ab9ed996bab26e2605f1942bfff2203aa9a8e90fa80c010ccf2e575dbfca3bd03d3322381343cdf6def3829bbe45db8693
+DIST libu2f-host-1.1.10.tar.xz 471676 BLAKE2B 5066eaaaeda3b8c015afa8946f0af3b1b90a34488d4c71811c0d8f57a3ed2e4c8cb3d82d2df147dcf13ac3c384522d22f25894ac3a2d994a75b288891a67640a SHA512 91c5bf3994f1d3c9bd144f54b14b0404d839c15bef3c318619decdf1bd37214bcff33927af78a9826ff7d0bc9907c912a0e31104ae68d3a727a8436f2a1dbf7a
DIST libu2f-host-1.1.3.tar.xz 469480 BLAKE2B b2a002fa694972e71aef73191608d079f1c13d98a2f40e06d25a6e50a3175100099adbc5b5067e5f1fe027042f99e198a07282df735ab4ff2eec63a4f5daf59a SHA512 6729dd35beaae1c96283f81794ac6c058ed6446f935a5cee7dc1a3db594201c9f049de6a58ac2e544e1c6ac0c1e9815cce5e2e46a6e45372e419078307a57f55
DIST libu2f-host-1.1.6.tar.xz 469380 BLAKE2B 7943b6dd61084952edb81ab2c93fd781d832f0ad07dff442c93464ecce57bde8a7b3d4aea5fa6801f39a5cbb272658ba86bf499f485bca35fa5fa314d609ff2f SHA512 499efac0243a7e5fadf6c456cc5530633337c07ab7dda52bd77b541b24ffd0337efe95cce499e73d6c46d312e737c044edcbdb4d41043b1e8721242d6e6ad20a
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
new file mode 100644
index 000000000000..74514141e2a9
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info udev user
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kernel_linux static-libs systemd"
+
+DEPEND="dev-libs/hidapi
+ dev-libs/json-c:="
+RDEPEND="${DEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~HIDRAW"
+
+pkg_setup() {
+ # The U2F device node will be owned by group 'plugdev'
+ # in non-systemd configurations
+ if ! use systemd; then
+ enewgroup plugdev
+ fi
+}
+
+src_install() {
+ default
+ if use kernel_linux; then
+ udev_dorules 70-u2f.rules
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if ! use systemd; then
+ elog "Users must be a member of the 'plugdev' group"
+ elog "to be able to access U2F devices"
+ fi
+}