summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-10-17 09:38:22 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-10-17 09:38:22 +0300
commit7fc75e34331ad38dcc02373a8c81ce065c3ebd58 (patch)
tree1f2b5f6b24fe3aaf4bd3a2f749484264d38c28bd /app-crypt/gpa/gpa-0.10.0.ebuild
parentcuda.eclass: fix circular dep for nvidia-cuda-toolkit (diff)
downloadgentoo-7fc75e34331ad38dcc02373a8c81ce065c3ebd58.tar.gz
gentoo-7fc75e34331ad38dcc02373a8c81ce065c3ebd58.tar.bz2
gentoo-7fc75e34331ad38dcc02373a8c81ce065c3ebd58.zip
app-crypt/gpa: version bump
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-crypt/gpa/gpa-0.10.0.ebuild')
-rw-r--r--app-crypt/gpa/gpa-0.10.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/gpa/gpa-0.10.0.ebuild b/app-crypt/gpa/gpa-0.10.0.ebuild
new file mode 100644
index 000000000000..3c2d680c6b31
--- /dev/null
+++ b/app-crypt/gpa/gpa-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
+HOMEPAGE="http://gpa.wald.intevation.org"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=app-crypt/gnupg-2:=
+ >=app-crypt/gpgme-1.5.0:=
+ >=dev-libs/libassuan-1.1.0
+ >=dev-libs/libgpg-error-1.4
+ >=x11-libs/gtk+-2.10.0:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ sed -i 's/Application;//' gpa.desktop
+}
+
+src_configure() {
+ econf \
+ --with-gpgme-prefix=/usr \
+ --with-libassuan-prefix=/usr \
+ $(use_enable nls) \
+ GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
+}