summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-06 14:56:51 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-06 17:20:50 +0200
commit8d534450b2db70fe0f9717f16d0d3a9305b844e2 (patch)
tree2a5e6bf789ef8582516cdff7a7beb88c237b7f6c /app-containers
parentdev-lang/dafny: clean environment in pkg_setup (diff)
downloadgentoo-8d534450b2db70fe0f9717f16d0d3a9305b844e2.tar.gz
gentoo-8d534450b2db70fe0f9717f16d0d3a9305b844e2.tar.bz2
gentoo-8d534450b2db70fe0f9717f16d0d3a9305b844e2.zip
app-containers/earthly: drop old 0.7.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.7.15.ebuild74
2 files changed, 0 insertions, 76 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index d30bcc9c6347..a0193b4587af 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,5 +1,3 @@
-DIST earthly-0.7.15-deps.tar.xz 152884116 BLAKE2B 69f937981605da5db306cdd7f06cdeb106bf907e85ea83f29a77c719d662003b562e7263a5eeb9e478682c019a3d7a265d4cf4ab1c5bcf2f37efbaa42e9ae326 SHA512 368700ce71c8791069d8c14abc6e1d4bf7c356d770641c4172e3e8910c176f0ba8cd5c5738e639da2905385d5d4a961f52b84d8e228fc3e323876f1cda16265e
-DIST earthly-0.7.15.tar.gz 7750609 BLAKE2B b727c6cde93abb3b3e39addc9e79c07fb21232902bca61b5a2b843d1c92b4b6628a1122eced0141b6be6c6678d80a7e473efc6513af07a416b3d6972e210defb SHA512 975d1c1c0055ed6e2884102f4d785833aea4c9257ba3f34e70eeea95c1215eb1dc769a036bdf036682d95dfa6bb30c35b897ff337b2af8b5d9d459f14ecc7cc4
DIST earthly-0.7.17-deps.tar.xz 152916336 BLAKE2B c54a1b6166cd55ac8417004c50c742c854a90bfd642f893d24b1a626498bbdfb02ef9e6b62ef79adac65db313b7819a000a673720a816159595c92d791d9c9d2 SHA512 df5db663b716cd8104b118cc421096b4ae1ccaf72a211a72c6a56812b8e0c8c890f4607dfa99dc3e240afca123793f6378adfb38a83c53facab5f39761e53ec1
DIST earthly-0.7.17.tar.gz 7755932 BLAKE2B e08d380673698e085cc5eb645337a709bf0ff3429f4565d15750e6f1d8aa82dc83d1f5c7aa155da163eb6b6376f275b171b88117b9a7903b23c1d7aba60fa38e SHA512 b495c5abf90397e044da3e394d859e02280c11b16f4c32f742624f7c97a51c597d32bdcc527cf5a99d4c5b09d1a238b7a6128d57e4be7cb0858e0f361fd0c597
DIST earthly-0.7.19-deps.tar.xz 152930992 BLAKE2B 436e66036a5772a8bb2f283522f064670b8bb9d8e811bf159db7c4a883d7a3be37e3acac3b003f21b806fe48a87b0aff9ea422b730b79c73d0ffcf08aeabc9c7 SHA512 154903533b406f8a2f4c7f7f41ad94ab09efd784c79ce4d579821e0d17dd9df5f783806d901e2c7a857467e4c543985847b379e167db57a0f5ed446ce78ec256
diff --git a/app-containers/earthly/earthly-0.7.15.ebuild b/app-containers/earthly/earthly-0.7.15.ebuild
deleted file mode 100644
index 8df3700e87c3..000000000000
--- a/app-containers/earthly/earthly-0.7.15.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- mkdir -p bin || die
-
- # Git SHA is needed at runtime by earthly to pull and bootstrap images.
- local git_sha
- if [[ ${PV} == 0.7.15 ]] ; then
- git_sha=ae8f65528ad37a278985de2e234deb42b91e308f
- else
- die 'Could not detect "git_sha", please update the ebuild.'
- fi
-
- local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${git_sha}
- -X main.Version=v${PV}
- "
- local -a go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o bin
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}