summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-13 17:51:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-13 18:50:58 +0200
commit46f3f9ef6f1c913ea7a06597cd0aa62e1c0dcd61 (patch)
tree09c8ee01d87c2b268fc528bddedbd4620f46ed2d /app-cdr
parentkde-apps/umbrello: 24.05.1 version bump (diff)
downloadgentoo-46f3f9ef6f1c913ea7a06597cd0aa62e1c0dcd61.tar.gz
gentoo-46f3f9ef6f1c913ea7a06597cd0aa62e1c0dcd61.tar.bz2
gentoo-46f3f9ef6f1c913ea7a06597cd0aa62e1c0dcd61.zip
app-cdr/dolphin-plugins-mountiso: 24.05.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index 04ecdc2f2324..a37c759b16f7 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,3 +1,4 @@
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
DIST dolphin-plugins-23.08.5.tar.xz 274124 BLAKE2B c8b43bd7f87c7221023e75e3f66b450844b379d5bfc95e37ce01dfe983ba3dc234a319da2aaf0596e6eb54319bc4310c718b57d52d070f0f86cd67c6f67a8c4b SHA512 2dd30070660df63b988cda2e14f3ddc27a0cf451119d2a6b121cb9cbeb8788b94498ef25ca434501843784a8e24c4539fe17cc0ab5a158befbc9db5792944852
DIST dolphin-plugins-24.05.0.tar.xz 304784 BLAKE2B dfd61af9d8cd6aa66b9295e7da343c6f077a7aed838b002eb055af29e66b6425f2dd8562f5a8a088dc39f2f73d42f5614f668c4e848435412bca7c2f6259ea11 SHA512 1d36fae869f5afabd394433f69e83fd603981ebef3d564f04e45cade250c6ccd54edc4e493339201aaea9d415fc87bf031485853619a9298ae86dffa1972e256
+DIST dolphin-plugins-24.05.1.tar.xz 306024 BLAKE2B 3b5c999c6eb2657e1d0e831f6f23942aa14515459a263217e62b1a04ccafe480cd7723d855ccecf3aba197f17ca172234d6f182681970a5a216bdb72a7357871 SHA512 0b26cf5e09b837f451d6e902f0aa6ce231327dd3eda480b4bff6987f6f0ea8688d9ff097681cef855e1a47b599c3092e183905193f15b0b905345362be1e1fdb
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild
new file mode 100644
index 000000000000..1c8dd99f2d53
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.3.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}