summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/dvdshrink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/dvdshrink')
-rw-r--r--app-cdr/dvdshrink/Manifest1
-rw-r--r--app-cdr/dvdshrink/dvdshrink-2.6.1_p10.ebuild48
-rw-r--r--app-cdr/dvdshrink/metadata.xml12
3 files changed, 61 insertions, 0 deletions
diff --git a/app-cdr/dvdshrink/Manifest b/app-cdr/dvdshrink/Manifest
new file mode 100644
index 000000000000..6f83e8c306e4
--- /dev/null
+++ b/app-cdr/dvdshrink/Manifest
@@ -0,0 +1 @@
+DIST dvdshrink-2.6.1-10mdk.tar.gz 1087571 SHA256 bbc30055130e3179490d8d48fb8cea7ad649c4704c55e4d93abf832ab43d78e9 SHA512 6766f95bd2bb29ef0877d9b22bc45eb2c508ad2d1a7bb99f84b3f858987fc098a696f15f953efe006bf9556a73f6aa0e6247afcdf8e4c5dad826ddba97f02c06 WHIRLPOOL b789d49badef052b030d01206db18650ced6a5ad64a92979c7abe7faee9f89c0979c7d2e43a80c68eb1be2957fd8316237b50205b3987a2fb9d3800c52867de6
diff --git a/app-cdr/dvdshrink/dvdshrink-2.6.1_p10.ebuild b/app-cdr/dvdshrink/dvdshrink-2.6.1_p10.ebuild
new file mode 100644
index 000000000000..03274bab9660
--- /dev/null
+++ b/app-cdr/dvdshrink/dvdshrink-2.6.1_p10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Scriptable DVD copy software"
+HOMEPAGE="http://dvdshrink.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P/_p/-}mdk.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=media-video/transcode-1.0.2-r2[dvd]
+ >=media-video/mjpegtools-1.8.0-r1
+ >=media-video/subtitleripper-0.3.4-r1
+ >=media-video/dvdauthor-0.6.11
+ >=app-cdr/dvd+rw-tools-6.1
+ gtk? ( >=dev-perl/gtk2-perl-1.104 )
+ >=app-text/gocr-0.40
+ virtual/cdrtools"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -e 's:applications/::g' -i usr/bin/dvdsfunctions \
+ -i usr/bin/xdvdshrink.pl || die "sed failed."
+}
+
+src_install() {
+ dobin usr/bin/{batchrip.sh,dvds{functions,hrink}} || die "dobin failed."
+
+ if use gtk; then
+ dobin usr/bin/xdvdshrink.pl || die "dobin failed."
+ fi
+
+ insinto /usr/share
+ doins -r usr/share/applications/dvdshrink || die "doins failed."
+
+ dodoc usr/share/doc/dvdshrink/{batchrip.txt,example.xml,README.txt}
+
+ doicon usr/share/icons/{batchrip.xpm,dvdshrink.xpm}
+ use gtk && make_desktop_entry xdvdshrink.pl xDVDShrink ${PN} AudioVideo
+}
diff --git a/app-cdr/dvdshrink/metadata.xml b/app-cdr/dvdshrink/metadata.xml
new file mode 100644
index 000000000000..f82fae79b6ae
--- /dev/null
+++ b/app-cdr/dvdshrink/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <longdescription>
+XDVDShrink is a project in BASH and Perl-Gtk2 that allows you to create fair-use
+archival copies of DVD content on single-layer writable DVDs.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">dvdshrink</remote-id>
+ </upstream>
+</pkgmetadata>