summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/cdrdao
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/cdrdao')
-rw-r--r--app-cdr/cdrdao/Manifest1
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild60
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.3-glibc212.patch12
-rw-r--r--app-cdr/cdrdao/metadata.xml12
4 files changed, 85 insertions, 0 deletions
diff --git a/app-cdr/cdrdao/Manifest b/app-cdr/cdrdao/Manifest
new file mode 100644
index 000000000000..e8d968a56756
--- /dev/null
+++ b/app-cdr/cdrdao/Manifest
@@ -0,0 +1 @@
+DIST cdrdao-1.2.3.tar.bz2 1428695 SHA256 8193cb8fa6998ac362c55807e89ad0b3c63edc6b01afaeb3d5042519527fb75e SHA512 36b14180acf476de062f5f31e2b9dece39e3cc7a84552e80a6714931fa35d6090ec90ddfcdbd2651d690be8ce3fc78d483aa13856c3c311bcc2f571f0040adf6 WHIRLPOOL 830d89a1ea2fe87c1b43a36d0f0d45bc372fc65beafa95057a13f0571d89ee43bd5f6fabfd643a481a3f4f8c4c758caff9fa5f60fffbefc4c976bf98133d89f7
diff --git a/app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild b/app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..0eed46b0c7a6
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
+HOMEPAGE="http://cdrdao.sourceforge.net/"
+if [[ ${PV/*_rc*} ]]
+then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+else
+ SRC_URI="http://www.poolshark.org/src/${P/_}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="gcdmaster encode mad vorbis"
+
+RDEPEND="virtual/cdrtools
+ encode? ( >=media-sound/lame-3.99 )
+ gcdmaster? (
+ dev-libs/libsigc++:2
+ >=dev-cpp/gtkmm-2.4:2.4
+ >=dev-cpp/libgnomeuimm-2.6:2.6
+ media-libs/libao
+ )
+ mad? (
+ media-libs/libmad
+ media-libs/libao
+ )
+ vorbis? (
+ media-libs/libvorbis
+ media-libs/libao
+ )
+ !app-cdr/cue2toc
+ !dev-util/pccts"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc212.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with gcdmaster xdao) \
+ $(use_with vorbis ogg-support) \
+ $(use_with mad mp3-support) \
+ $(use_with encode lame)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog CREDITS NEWS README{,.PlexDAE}
+}
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.3-glibc212.patch b/app-cdr/cdrdao/files/cdrdao-1.2.3-glibc212.patch
new file mode 100644
index 000000000000..dbfc96cb93bf
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.3-glibc212.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/332237
+
+--- dao/ScsiIf-linux.cc
++++ dao/ScsiIf-linux.cc
+@@ -30,6 +30,7 @@
+ #include <asm/param.h>
+ #include <scsi/scsi.h>
+ #include <scsi/sg.h>
++#include <sys/stat.h>
+
+ #include "ScsiIf.h"
+ #include "sg_err.h"
diff --git a/app-cdr/cdrdao/metadata.xml b/app-cdr/cdrdao/metadata.xml
new file mode 100644
index 000000000000..de17ceb3ec77
--- /dev/null
+++ b/app-cdr/cdrdao/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-optical</herd>
+<longdescription>
+ CD command line recording, ripping and copying tool. Especially ISOs- and
+ bin/cue-files are handled very well.
+</longdescription>
+<use>
+ <flag name='gcdmaster'>Enable building of gcdmaster application</flag>
+</use>
+</pkgmetadata>