summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-29 23:38:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-29 23:38:18 +0200
commit571a5f8a277f1f29a6828f29854ef54beedf2efc (patch)
treecd7a000584e50083b1572b8916e08a2c4f16357f /app-benchmarks/stress-ng
parentapp-benchmarks/geekbench: bump to EAPI8 (diff)
downloadgentoo-571a5f8a277f1f29a6828f29854ef54beedf2efc.tar.gz
gentoo-571a5f8a277f1f29a6828f29854ef54beedf2efc.tar.bz2
gentoo-571a5f8a277f1f29a6828f29854ef54beedf2efc.zip
app-benchmarks/stress-ng: bump to version 0.13.06
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks/stress-ng')
-rw-r--r--app-benchmarks/stress-ng/Manifest1
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.13.06.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/Manifest b/app-benchmarks/stress-ng/Manifest
index 5a47cfbb9c57..f9b4c96b6be1 100644
--- a/app-benchmarks/stress-ng/Manifest
+++ b/app-benchmarks/stress-ng/Manifest
@@ -1 +1,2 @@
DIST stress-ng-0.13.05.tar.xz 590340 BLAKE2B 214e98ef5db575a0835ccef15d9145bba6d25774bb26ce1ac2ffa3b29309a62416752b298ccb5b1ce91ad40a3c68dee7ada7c59fd85c06d8372e24c72a927480 SHA512 39a1622d63e88a1d0f535b36c57a01f734e686a3f4f2dc9dcf69154e7b0e4986c6bd654a42803cc3dc0e9a22151db9e2ae79a772758e9d80beb22bd39492d13a
+DIST stress-ng-0.13.06.tar.gz 1014981 BLAKE2B a93ff571919707568cd0162479e47c6241b4081713cfa88b30594227d01f9af2a6e3ad759ba62f5f5485322d68768ba1ea19087d07281fa1c2b949bcac99f70e SHA512 7aefc794edaa5799f96dd4afe099b747d532e4367bd372b9ed29db03f8276322113509fdd4885500864d292beeb9f407dc3f2ef2a04f92b65f240ee73eb174bb
diff --git a/app-benchmarks/stress-ng/stress-ng-0.13.06.ebuild b/app-benchmarks/stress-ng/stress-ng-0.13.06.ebuild
new file mode 100644
index 000000000000..a91c3da6c136
--- /dev/null
+++ b/app-benchmarks/stress-ng/stress-ng-0.13.06.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="https://github.com/ColinIanKing/stress-ng"
+SRC_URI="https://github.com/ColinIanKing/${PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0=
+ sys-apps/attr
+ sys-apps/keyutils:=
+ sys-libs/libcap
+ sys-libs/zlib
+ virtual/libcrypt:=
+"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "README.Android" "TODO" "syscalls.txt" )
+
+src_compile() {
+ export MAN_COMPRESS=0
+ export VERBOSE=1
+ tc-export CC
+
+ default
+}
+
+pkg_postinst() {
+ optfeature "AppArmor support" sys-libs/libapparmor
+ optfeature "SCTP support" net-misc/lksctp-tools
+}