summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/bashmark
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/bashmark')
-rw-r--r--app-benchmarks/bashmark/Manifest1
-rw-r--r--app-benchmarks/bashmark/bashmark-0.6.2.ebuild27
-rw-r--r--app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch12
-rw-r--r--app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch48
-rw-r--r--app-benchmarks/bashmark/files/bashmark-0.6.2-gcc47.patch29
-rw-r--r--app-benchmarks/bashmark/metadata.xml5
6 files changed, 122 insertions, 0 deletions
diff --git a/app-benchmarks/bashmark/Manifest b/app-benchmarks/bashmark/Manifest
new file mode 100644
index 000000000000..1054a31e0780
--- /dev/null
+++ b/app-benchmarks/bashmark/Manifest
@@ -0,0 +1 @@
+DIST bashmark-0.6.2.tar.bz2 21944 SHA256 cdef5531069ccb9242a6c0ae3298be85053784782c4fe4a9d9518215dd2f085f SHA512 43935b44c1b871d724aca0e1a6dfd99c73c29ec276c4127186e8dc6c7b27d57554b8b32a7e2372cd0b78eb584df7ee169f51f47e6666f61eaacbe35c5d4074f8 WHIRLPOOL 93b0596d69819fecf2969edb132466d24fba4cc9a1f5d2ba5cac5a95735dd34af133afb01beca8f9588f62812c76b043acf13554dacec148636f4bbed1deff9d
diff --git a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
new file mode 100644
index 000000000000..571160233f73
--- /dev/null
+++ b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Geno's cross platform benchmarking suite"
+HOMEPAGE="http://bashmark.coders-net.de"
+
+SRC_URI="http://bashmark.coders-net.de/download/src/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_install() {
+ dobin bashmark
+ dodoc ChangeLog
+}
diff --git a/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch b/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch
new file mode 100644
index 000000000000..6c01fd934e5d
--- /dev/null
+++ b/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch
@@ -0,0 +1,12 @@
+diff -ru bashmark-0.6.2-orig/makefile bashmark-0.6.2/makefile
+--- bashmark-0.6.2-orig/makefile 2007-10-08 23:01:06.000000000 +0300
++++ bashmark-0.6.2/makefile 2007-10-08 23:01:22.000000000 +0300
+@@ -10,7 +10,7 @@
+ BIN = bashmark
+
+ $(BIN): $(OBJ)
+- $(LD) $(LDFLAGS) $(CXXFLAGS) $(OBJ) -o $(BIN)
++ $(LD) $(CXXFLAGS) $(OBJ) $(LDFLAGS) -o $(BIN)
+
+
+ Benchmark.o:
diff --git a/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
new file mode 100644
index 000000000000..625abdab397b
--- /dev/null
+++ b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
@@ -0,0 +1,48 @@
+diff -NrU5 bashmark-0.6.2.orig/Benchmark.cpp bashmark-0.6.2/Benchmark.cpp
+--- bashmark-0.6.2.orig/Benchmark.cpp 2008-06-29 11:53:07.000000000 +0200
++++ bashmark-0.6.2/Benchmark.cpp 2008-06-29 11:54:02.000000000 +0200
+@@ -15,11 +15,11 @@
+ * *
+ * You should have received a copy of the GNU General Public License *
+ * along with this software; if not, write to the Free Software *
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+-#include <string>
++#include <cstring>
+ #include "Benchmark.hpp"
+ #include "Stopwatch.hpp"
+ #include "Main.hpp"
+
+
+diff -NrU5 bashmark-0.6.2.orig/main.cpp bashmark-0.6.2/main.cpp
+--- bashmark-0.6.2.orig/main.cpp 2008-06-29 11:53:07.000000000 +0200
++++ bashmark-0.6.2/main.cpp 2008-06-29 11:56:40.000000000 +0200
+@@ -17,10 +17,11 @@
+ * along with this software; if not, write to the Free Software *
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+
+ #include <sstream>
++#include <cstring>
+ using std::stringstream;
+
+
+ #include "Output.hpp"
+ #include "Sysinfo.hpp"
+diff -NrU5 bashmark-0.6.2.orig/Sysinfo.cpp bashmark-0.6.2/Sysinfo.cpp
+--- bashmark-0.6.2.orig/Sysinfo.cpp 2008-06-29 11:53:07.000000000 +0200
++++ bashmark-0.6.2/Sysinfo.cpp 2008-06-29 11:55:58.000000000 +0200
+@@ -15,11 +15,12 @@
+ * *
+ * You should have received a copy of the GNU General Public License *
+ * along with this software; if not, write to the Free Software *
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+-
++
++#include <cstring>
+ #include "Sysinfo.hpp"
+
+ using Geno::Sysinfo;
+ using Geno::Cpu_Info;
+
diff --git a/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc47.patch b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc47.patch
new file mode 100644
index 000000000000..cb26d32b1fd6
--- /dev/null
+++ b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc47.patch
@@ -0,0 +1,29 @@
+ https://bugs.gentoo.org/422577
+
+ error: 'usleep' was not declared in this scope
+
+
+ Benchmark.cpp | 1 +
+ main.cpp | 1 +
+ 2 files changed, 2 insertions(+)
+
+--- a/Benchmark.cpp
++++ b/Benchmark.cpp
+@@ -18,6 +18,7 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+ #include <cstring>
++#include <unistd.h>
+ #include "Benchmark.hpp"
+ #include "Stopwatch.hpp"
+ #include "Main.hpp"
+--- a/main.cpp
++++ b/main.cpp
+@@ -20,6 +20,7 @@
+
+ #include <sstream>
+ #include <cstring>
++#include <unistd.h>
+ using std::stringstream;
+
+
diff --git a/app-benchmarks/bashmark/metadata.xml b/app-benchmarks/bashmark/metadata.xml
new file mode 100644
index 000000000000..f50ab76d5abd
--- /dev/null
+++ b/app-benchmarks/bashmark/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+</pkgmetadata>