summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-10-01 11:02:08 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-10-01 11:02:39 +0200
commit1c659d060363f621c66c816bf41f0bce9be688eb (patch)
treee8b9117d5ec935f65b72aa142a249fba5244cd14 /app-backup
parentsys-devel/clang: Fix test failure due to '.src' in path (diff)
downloadgentoo-1c659d060363f621c66c816bf41f0bce9be688eb.tar.gz
gentoo-1c659d060363f621c66c816bf41f0bce9be688eb.tar.bz2
gentoo-1c659d060363f621c66c816bf41f0bce9be688eb.zip
app-backup/restic: use older go module behavior
Go 1.13 changed the default GO111MODULE value, and Restic hasn't been updated since July to account for this, so let's opt-in to the old behavior so that the build system still works. Closes: https://bugs.gentoo.org/693764 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/restic/restic-0.9.5.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-backup/restic/restic-0.9.5.ebuild b/app-backup/restic/restic-0.9.5.ebuild
index 6b97caddd1d5..538885775d0b 100644
--- a/app-backup/restic/restic-0.9.5.ebuild
+++ b/app-backup/restic/restic-0.9.5.ebuild
@@ -32,12 +32,12 @@ src_compile() {
-o restic ${EGO_PN}/cmd/restic
)
- GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ GO111MODULE=off GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
go build "${mygoargs[@]}" || die
}
src_test() {
- GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ GO111MODULE=off GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
go test -timeout 30m -v -work -x ${EGO_PN}/cmd/... ${EGO_PN}/internal/... || die
}