summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernandez-Alcon, Jose <jose@atlantis.blackmagic.io>2017-04-03 11:51:31 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-04-03 17:45:40 -0400
commitafa00281f4738f96127137eedc347b66ba46837c (patch)
tree1ef88a44700eca4cfb11562652774081ef1b8a47 /app-backup/spideroak-bin
parentsys-power/powertop: arm ppc stable (bug 614320). (diff)
downloadgentoo-afa00281f4738f96127137eedc347b66ba46837c.tar.gz
gentoo-afa00281f4738f96127137eedc347b66ba46837c.tar.bz2
gentoo-afa00281f4738f96127137eedc347b66ba46837c.zip
app-backup/spideroak-bin: version bump to 6.1.5, issue #582660
Reported-by: Frank Krömmelbein <kroemmelbein@gmx.de>
Diffstat (limited to 'app-backup/spideroak-bin')
-rw-r--r--app-backup/spideroak-bin/Manifest2
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-6.1.5.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index fde426b92475..e253b7b6c91f 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -1,2 +1,4 @@
DIST spideroak-bin-6.1.3_amd64.deb 26655852 SHA256 65ecab3096e6de675fd9facf81f387775c2419158112c4914447fa0af07d8015 SHA512 f9d4e4178721609ec4a544ac8b84e581088ad9be5aaf3aa68de12e2d7e17d7c148d9a619917b69ecfd9c08087d1987b0b67081673b81f56908089caa9ab0edc5 WHIRLPOOL 6751d84d9739bc66f189b52cf944544213f10e978b9e2cb1b85fcf1303fb4ae0373d7bf9633638586cceea659c2448a442b459fdaefc7306854f8b1f58c189d9
DIST spideroak-bin-6.1.3_x86.deb 26173318 SHA256 50fd7d442291bb9ec64d51308444c83b7d76d55bafcc3e9f5d3009e6a49eee0f SHA512 0ddf1be909b44042e3fe0f7e791558e50c649a3d4472c3a05c78835c593d6db3369c0e862b79f2a4812232503346defc1c889fbc4c701a125d3364810b524481 WHIRLPOOL 2e19e4ac0f9028acea19eb2f395faba2031959c09544c07a7f10c690f67317558ac0fbdf2e1fe1b52a922e4ac9480486348b0c4cf053b03336018d3aef7f2dab
+DIST spideroak-bin-6.1.5_amd64.deb 26882606 SHA256 7ef458381c17f7a3712043aa672b5509500e7e6999cd52ba5d85ba76f7a29d2c SHA512 c23e41d359879ce671f8af66e32d08affe10c92492ed46dc6eea5942f14190d28a4b1b96722959bfcec98b05f9176c0a959c93c32bf22709139332b42d805a52 WHIRLPOOL 8f9b56f091951dafb6849cfbafd60314708dd5a5deed0852d5bb06869b36f1fa5d8e55508407c5bbf34024523531bfe26325fce7895ac04b59f6f1dd1aa50c58
+DIST spideroak-bin-6.1.5_x86.deb 26405076 SHA256 a001e464b87406e775f421ff041fbc80a3f3b33548c792a095c9632e137a3e89 SHA512 4aa87c2fd35569bb4acaf5492ca520d66bb9d53c5a53d5e8f418ae0518cb143f35bc769a7d37bc1ea6e4536b944780a3403d3800c45973bed537f573f3e07d0a WHIRLPOOL 7471b8ebf394cbcbc05400cc0e0c390ea30d92194567458b6955bd9a25f5f40fbe27c52e30767e467aa4f45ecf6fa304b82ab60bf30d1408846c4cff7f4087b9
diff --git a/app-backup/spideroak-bin/spideroak-bin-6.1.5.ebuild b/app-backup/spideroak-bin/spideroak-bin-6.1.5.ebuild
new file mode 100644
index 000000000000..885e81a1a1db
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-6.1.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils unpacker
+
+SRC_URI_BASE="https://spideroak.com/getbuild?platform=ubuntu"
+
+DESCRIPTION="Secure free online backup, storage, and sharing system"
+HOMEPAGE="https://spideroak.com"
+SRC_URI="x86? ( ${SRC_URI_BASE}&arch=i386&version=${PV} -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}&arch=x86_64&version=${PV} -> ${P}_amd64.deb )"
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ #Remove the libraries that break compatibility in modern systems
+ #SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}