summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/duplicity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest4
-rw-r--r--app-backup/duplicity/duplicity-0.6.22.ebuild37
-rw-r--r--app-backup/duplicity/duplicity-0.6.23-r1.ebuild38
-rw-r--r--app-backup/duplicity/duplicity-0.6.24.ebuild49
-rw-r--r--app-backup/duplicity/duplicity-0.6.25.ebuild49
-rw-r--r--app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch10
-rw-r--r--app-backup/duplicity/metadata.xml11
7 files changed, 198 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
new file mode 100644
index 000000000000..abd55be70ed2
--- /dev/null
+++ b/app-backup/duplicity/Manifest
@@ -0,0 +1,4 @@
+DIST duplicity-0.6.22.tar.gz 1257082 SHA256 6f489b0445681f0697488f3d4097b4c56a7fe8a5fea5fadd2e431724039c5a12 SHA512 0fe838707c91e2933f0edc4b9258edd081a2e0b8ed0cd31bf229f08883b60ca9cb8d44f70b00632a926548d375417e3a5f9747a0c3eeef15bfa541a27062dfd5 WHIRLPOOL 63732f177e30dde1bc7bf74063dd56bc22654b4f2b787ea47e6d44364ee98fafe418954d0c80a152e25f7c1016abc5507350ac929de2a67eee1d1d30cc47856d
+DIST duplicity-0.6.23.tar.gz 1260261 SHA256 7a17f1e10395dedcf3204bc53925bb9dcbbf2a7552c9b096ebe727eceb9c0c60 SHA512 35c3facf9f44e117c74d880bef3f50c2f6a778fac31b38398934007befbe5dedb3f56ccdd592c231c0835baaba905ca942a889e0a1358c1b79570db08376385a WHIRLPOOL 6edffb363c48a90a6c3dc9d7a8ccdb22a6390e422255deca7a84b5e87e13a865fa325313f50bea52cdea7b3ae6b880e939c6cd58d605d4cc5df0e7f191523145
+DIST duplicity-0.6.24.tar.gz 1268175 SHA256 1d41d756638f55106f9501c3db94ccbc6568aa856ba531e07ed2cfb760b62450 SHA512 5bb783ef6ddbfa6672279287b01f44e33256829971e7b8bbe26d648d2c78d438018bddd977281b8a1ff7e5c1505a3b60fe03ecb5ba8022a597f9f952b2815273 WHIRLPOOL f42120cc403a987a9e5f747e1f7502059772f9c2fdb1afb92caa354676b7089736cd9524d08ef6677872a5019e17d2092513cc5544beed5fb0d80158742e1ebf
+DIST duplicity-0.6.25.tar.gz 1269583 SHA256 ac44f44abc1c5fe775a49b77e722d238c0b3bbb105e083fd505e2dca8e2c1725 SHA512 17304e38990e0a34aa4bae9f2d12a99ece031ac048667fba27afbcc32e1fb8455a2672426e49edb543bd7e345dc74f784f34c26ec2e1651eb10ba479868e04a0 WHIRLPOOL 8af905551078e30529dd31bd7de8f783ec0875c57e9f4d93388c5e407e9aecd19c0d151d3eb4d718cb5ea4dd649bb835611604f5ee5ad33f04355846a406d39d
diff --git a/app-backup/duplicity/duplicity-0.6.22.ebuild b/app-backup/duplicity/duplicity-0.6.22.ebuild
new file mode 100644
index 000000000000..02ccc6a4080e
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+"
+RDEPEND="${DEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/duplicity-0.6.23-r1.ebuild b/app-backup/duplicity/duplicity-0.6.23-r1.ebuild
new file mode 100644
index 000000000000..b89e6d835b12
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.23-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+RDEPEND="${DEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/duplicity-0.6.24.ebuild b/app-backup/duplicity/duplicity-0.6.24.ebuild
new file mode 100644
index 000000000000..cf6ff8c44d61
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.24.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+# workaround until failing test is fixed
+PATCHES=( "${FILESDIR}"/${P}-skip-test.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/duplicity-0.6.25.ebuild b/app-backup/duplicity/duplicity-0.6.25.ebuild
new file mode 100644
index 000000000000..f6c05879100e
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.25.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+# workaround until failing test is fixed
+PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch b/app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch
new file mode 100644
index 000000000000..ef6d959685be
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch
@@ -0,0 +1,10 @@
+--- duplicity-0.6.24/testing/functional/test_final.py
++++ duplicity-0.6.24/testing/functional/test_final.py
+@@ -156,6 +156,7 @@
+ self.run_duplicity(options=["remove-older-than", "50000", "--force", self.backend_url])
+ self.assertEqual(self.get_backend_files(), second_chain)
+
++ @unittest.skip('skip failing test')
+ def test_piped_password(self):
+ """Make sure that prompting for a password works"""
+ self.set_environ("PASSPHRASE", None)
diff --git a/app-backup/duplicity/metadata.xml b/app-backup/duplicity/metadata.xml
new file mode 100644
index 000000000000..5052c4e13097
--- /dev/null
+++ b/app-backup/duplicity/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="s3">Support for backing up to the Amazon S3 system</flag>
+ </use>
+</pkgmetadata>