summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-03-28 14:53:21 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-03-28 14:56:43 +0200
commitc1d710621232aa83cff3ae34fdf5e17a500dca9c (patch)
tree27639e418b8edcbf95ce44d3fd31de7bc9188020 /app-backup/borgbackup/borgbackup-1.1.16.ebuild
parentsys-auth/elogind: 246.10 version bump. (diff)
downloadgentoo-c1d710621232aa83cff3ae34fdf5e17a500dca9c.tar.gz
gentoo-c1d710621232aa83cff3ae34fdf5e17a500dca9c.tar.bz2
gentoo-c1d710621232aa83cff3ae34fdf5e17a500dca9c.zip
app-backup/borgbackup: 1.1.16 version bump; drop old.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'app-backup/borgbackup/borgbackup-1.1.16.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.16.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-backup/borgbackup/borgbackup-1.1.16.ebuild b/app-backup/borgbackup/borgbackup-1.1.16.ebuild
new file mode 100644
index 000000000000..4e0cf2f81ce8
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-1.1.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/borg.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+# Unfortunately we have a file conflict with app-office/borg, bug #580402
+RDEPEND="
+ !!app-office/borg
+ app-arch/lz4
+ virtual/acl
+ dev-python/llfuse[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+
+DEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/*
+}