summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-01 22:17:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-01 22:23:04 +0300
commit3ad06922103bc963750b01debac3e269517fe3ea (patch)
tree17dd042b849b14ef7bd75fd152a41c6b89858830 /app-arch
parentapp-arch/7zip: use https for metadata.xml (diff)
downloadgentoo-3ad06922103bc963750b01debac3e269517fe3ea.tar.gz
gentoo-3ad06922103bc963750b01debac3e269517fe3ea.tar.bz2
gentoo-3ad06922103bc963750b01debac3e269517fe3ea.zip
app-arch/7zip: drop 23.01, 24.05, 24.06
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/7zip/7zip-23.01.ebuild110
-rw-r--r--app-arch/7zip/7zip-24.05.ebuild110
-rw-r--r--app-arch/7zip/7zip-24.06.ebuild110
-rw-r--r--app-arch/7zip/Manifest6
4 files changed, 0 insertions, 336 deletions
diff --git a/app-arch/7zip/7zip-23.01.ebuild b/app-arch/7zip/7zip-23.01.ebuild
deleted file mode 100644
index 0d983a22a12f..000000000000
--- a/app-arch/7zip/7zip-23.01.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edos2unix flag-o-matic toolchain-funcs
-
-NO_DOT_PV=$(ver_rs 1- '')
-DESCRIPTION="Free file archiver for extremely high compression"
-HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is only used for docs
-SRC_URI="
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
-"
-S="${WORKDIR}"
-
-LICENSE="LGPL-2 BSD rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="uasm jwasm rar"
-REQUIRED_USE="?? ( uasm jwasm )"
-
-DOCS=( readme.txt History.txt License.txt )
-HTML_DOCS=( MANUAL )
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- uasm? ( dev-lang/uasm )
- jwasm? ( dev-lang/jwasm )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-respect-build-env.patch"
-)
-
-# TODO(NRK): also build and install the library
-# TODO(NRK): make it so this package can be used as a drop-in replacement
-# for app-arch/p7zip ??
-
-pkg_setup() {
- # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
- # TLDR; every combination of options (clang|gcc)+(asm/noasm)
- # has a dedicated makefile & builddir
- mfile="cmpl"
- if tc-is-clang; then
- mfile="${mfile}_clang"
- bdir=c
- elif tc-is-gcc; then
- mfile="${mfile}_gcc"
- bdir=g
- else
- die "Unsupported compiler: $(tc-getCC)"
- fi
- if use jwasm || use uasm ; then
- mfile="${mfile}_x64"
- bdir="${bdir}_x64"
- fi
- export mfile="${mfile}.mak"
- export bdir
-}
-
-src_prepare() {
- # patch doesn't deal with CRLF even if file+patch match
- # not even with --ignore-whitespace, --binary or --force
- pushd "./CPP/7zip" || die "Unable to switch directory"
- edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
- popd >/dev/null || die "Unable to switch directory"
-
- default
-}
-
-src_compile() {
- pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
-
- # avoid executable stack when using uasm/jwasm, harmless otherwise
- append-ldflags -Wl,-z,noexecstack
- export G_CFLAGS=${CFLAGS}
- export G_CXXFLAGS=${CXXFLAGS}
- export G_LDFLAGS=${LDFLAGS}
-
- local args=(
- -f "../../${mfile}"
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- )
- # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
- # whether it's defined or not. so in case user has `rar` enabled
- # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
- if ! use rar; then
- # disables non-free rar code but allows listing and extracting
- # non-compressed rar archives
- args+=( DISABLE_RAR_COMPRESS=1 )
- fi
- if use jwasm; then
- args+=( USE_JWASM=1 )
- elif use uasm; then
- args+=( MY_ASM=uasm )
- fi
-
- mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
- emake ${args[@]}
- popd > /dev/null || die "Unable to switch directory"
-}
-
-src_install() {
- dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
- einstalldocs
-}
diff --git a/app-arch/7zip/7zip-24.05.ebuild b/app-arch/7zip/7zip-24.05.ebuild
deleted file mode 100644
index 0d983a22a12f..000000000000
--- a/app-arch/7zip/7zip-24.05.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edos2unix flag-o-matic toolchain-funcs
-
-NO_DOT_PV=$(ver_rs 1- '')
-DESCRIPTION="Free file archiver for extremely high compression"
-HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is only used for docs
-SRC_URI="
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
-"
-S="${WORKDIR}"
-
-LICENSE="LGPL-2 BSD rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="uasm jwasm rar"
-REQUIRED_USE="?? ( uasm jwasm )"
-
-DOCS=( readme.txt History.txt License.txt )
-HTML_DOCS=( MANUAL )
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- uasm? ( dev-lang/uasm )
- jwasm? ( dev-lang/jwasm )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-respect-build-env.patch"
-)
-
-# TODO(NRK): also build and install the library
-# TODO(NRK): make it so this package can be used as a drop-in replacement
-# for app-arch/p7zip ??
-
-pkg_setup() {
- # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
- # TLDR; every combination of options (clang|gcc)+(asm/noasm)
- # has a dedicated makefile & builddir
- mfile="cmpl"
- if tc-is-clang; then
- mfile="${mfile}_clang"
- bdir=c
- elif tc-is-gcc; then
- mfile="${mfile}_gcc"
- bdir=g
- else
- die "Unsupported compiler: $(tc-getCC)"
- fi
- if use jwasm || use uasm ; then
- mfile="${mfile}_x64"
- bdir="${bdir}_x64"
- fi
- export mfile="${mfile}.mak"
- export bdir
-}
-
-src_prepare() {
- # patch doesn't deal with CRLF even if file+patch match
- # not even with --ignore-whitespace, --binary or --force
- pushd "./CPP/7zip" || die "Unable to switch directory"
- edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
- popd >/dev/null || die "Unable to switch directory"
-
- default
-}
-
-src_compile() {
- pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
-
- # avoid executable stack when using uasm/jwasm, harmless otherwise
- append-ldflags -Wl,-z,noexecstack
- export G_CFLAGS=${CFLAGS}
- export G_CXXFLAGS=${CXXFLAGS}
- export G_LDFLAGS=${LDFLAGS}
-
- local args=(
- -f "../../${mfile}"
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- )
- # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
- # whether it's defined or not. so in case user has `rar` enabled
- # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
- if ! use rar; then
- # disables non-free rar code but allows listing and extracting
- # non-compressed rar archives
- args+=( DISABLE_RAR_COMPRESS=1 )
- fi
- if use jwasm; then
- args+=( USE_JWASM=1 )
- elif use uasm; then
- args+=( MY_ASM=uasm )
- fi
-
- mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
- emake ${args[@]}
- popd > /dev/null || die "Unable to switch directory"
-}
-
-src_install() {
- dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
- einstalldocs
-}
diff --git a/app-arch/7zip/7zip-24.06.ebuild b/app-arch/7zip/7zip-24.06.ebuild
deleted file mode 100644
index 59e13dc0c5e5..000000000000
--- a/app-arch/7zip/7zip-24.06.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edos2unix flag-o-matic toolchain-funcs
-
-NO_DOT_PV=$(ver_rs 1- '')
-DESCRIPTION="Free file archiver for extremely high compression"
-HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is only used for docs
-SRC_URI="
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
-"
-S="${WORKDIR}"
-
-LICENSE="LGPL-2 BSD rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="uasm jwasm rar"
-REQUIRED_USE="?? ( uasm jwasm )"
-
-DOCS=( readme.txt History.txt License.txt )
-HTML_DOCS=( MANUAL )
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- uasm? ( dev-lang/uasm )
- jwasm? ( dev-lang/jwasm )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-24.05-respect-build-env.patch"
-)
-
-# TODO(NRK): also build and install the library
-# TODO(NRK): make it so this package can be used as a drop-in replacement
-# for app-arch/p7zip ??
-
-pkg_setup() {
- # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
- # TLDR; every combination of options (clang|gcc)+(asm/noasm)
- # has a dedicated makefile & builddir
- mfile="cmpl"
- if tc-is-clang; then
- mfile="${mfile}_clang"
- bdir=c
- elif tc-is-gcc; then
- mfile="${mfile}_gcc"
- bdir=g
- else
- die "Unsupported compiler: $(tc-getCC)"
- fi
- if use jwasm || use uasm ; then
- mfile="${mfile}_x64"
- bdir="${bdir}_x64"
- fi
- export mfile="${mfile}.mak"
- export bdir
-}
-
-src_prepare() {
- # patch doesn't deal with CRLF even if file+patch match
- # not even with --ignore-whitespace, --binary or --force
- pushd "./CPP/7zip" || die "Unable to switch directory"
- edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
- popd >/dev/null || die "Unable to switch directory"
-
- default
-}
-
-src_compile() {
- pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
-
- # avoid executable stack when using uasm/jwasm, harmless otherwise
- append-ldflags -Wl,-z,noexecstack
- export G_CFLAGS=${CFLAGS}
- export G_CXXFLAGS=${CXXFLAGS}
- export G_LDFLAGS=${LDFLAGS}
-
- local args=(
- -f "../../${mfile}"
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- )
- # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
- # whether it's defined or not. so in case user has `rar` enabled
- # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
- if ! use rar; then
- # disables non-free rar code but allows listing and extracting
- # non-compressed rar archives
- args+=( DISABLE_RAR_COMPRESS=1 )
- fi
- if use jwasm; then
- args+=( USE_JWASM=1 )
- elif use uasm; then
- args+=( MY_ASM=uasm )
- fi
-
- mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
- emake ${args[@]}
- popd > /dev/null || die "Unable to switch directory"
-}
-
-src_install() {
- dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
- einstalldocs
-}
diff --git a/app-arch/7zip/Manifest b/app-arch/7zip/Manifest
index 763dd2f63f9e..b9f9fdee7c9d 100644
--- a/app-arch/7zip/Manifest
+++ b/app-arch/7zip/Manifest
@@ -1,8 +1,2 @@
-DIST 7z2301-linux-x64.tar.xz 1527700 BLAKE2B 35dc74f0a7a4e586ea5ae969dce72c14e0231822630d2d70f24e1c911cea0492354a258ef65096a6ce0da1510117c12466bc6cda577cdf9e8e74ede17e47f23e SHA512 d3549468de8fd161e4c9233fa0b170af1f28c74749d20f3d0eeb3873857f6c6d2cc0777d564e6a79be7cc21c9e982e10710a795320428dc51db809a8d0f9454e
-DIST 7z2301-src.tar.xz 1378588 BLAKE2B 348484b24b39db70e513fe50d79954ea0e2dd669f83e3601fa796c8f0ca4734132ca20fac8cda9b8ba550bad9146627fc0ae07056abb99028ef6d825b6a533bd SHA512 e39f660c023aa65e55388be225b5591fe2a5c9138693f3c9107e2eb4ce97fafde118d3375e01ada99d29de9633f56221b5b3d640c982178884670cd84c8aa986
-DIST 7z2405-linux-x64.tar.xz 1553872 BLAKE2B d6c0bd4eb81f4112bfe50bf6affc68021b03d059076af5519a41c8d471e978ad2b4acc8f67c650070f9d07c518741a0146579ddfb8d56fd125f6db0beece0990 SHA512 13f97236157e2761a0bf406b08fba13a1ecc6d5663fb38f8dfe3b87f3910ba34fd359d8b36bea5135319543f31ec1e210eb512ea9864d9b140c336b9e416c313
-DIST 7z2405-src.tar.xz 1486772 BLAKE2B 609c7ae8b89e56e747ebfecb25108d8918138f48f0f2ed73183c76101ddd3615aafb9eb7823be0de2a434b450587e01f476d2ed092628a311b6e4ed091e06260 SHA512 d340adfa68e818dd3d3aa411780c81532fa37b6649178b81ec3739725f83e0bc3c01744612b2d467f4d0c2cc984dd35488406d7baee185cf372acebd9c0123a7
-DIST 7z2406-linux-x64.tar.xz 1551724 BLAKE2B e4cc8141b074209b58018e6aeb4b91f140160d5d52e1fba59da2d0cfcd41c488cbfa4bda99bdedd4915ca3c3bcca50e7f7f4289f44ce120577c8b632d2f7bf07 SHA512 fce2b8e9f26f092209613dc058a267ddf24c474a80b7e9837014fdaeab53bb892b7181561ca90048ca593fe29e010b8221e078c9c3ab9815baf23bc9caf3e829
-DIST 7z2406-src.tar.xz 1487008 BLAKE2B 0f8dd19a031520a9c233725e376bca06c91b9b513bc802a54b92ea046ae3dda69a293561938a1e4467d01333d46427bfee7a055c8b62cab7a9d04cf8262fe4eb SHA512 02c6d7d045ba0dc0e8533f471f3c138f0d6549b59594095cb81a2f0e602627bd6a49df3fd680e21400a908006121ff7ba370086db9bde639f79b821bb4c9707a
DIST 7z2407-linux-x64.tar.xz 1554932 BLAKE2B 9229fdac09148c50032656743aba0f8ce1ec06b7fd2dad2c693dc299c5f83fc093ba047e9c3c3971bf4cc9387b0db52c84167202ed7fcecfcc6f5bc508d04ada SHA512 31b5bb832e73f3c2fd0437873fe6130b8d1bd1bea8320d1b27d06bf40dd737758732eb3664fab2c36417b96ffc5daca6607b6f1aefdaa9e697122da60e37a728
DIST 7z2407-src.tar.xz 1488556 BLAKE2B 42b4f9553aaa4797e80a2d50073ff0e77b5261e50766f8c596a632fb013ac1514a2963f27b924485f07728d13a4536c69911867e3728e8f8604ec25fc4c6824e SHA512 0299e5c1e1dfd33ecf22077f812da1f25bf2146a713c7a7e2498d639520f21f029e853914e66a84d1edfc5d721e1f3d914a3171ab336a406a94bc82d5b2d8e5d