summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-16 09:51:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-16 10:10:55 +0200
commit1d4dc993580b6b744c5889e594bb89d5523854c7 (patch)
tree4db4e17160229db010a6ff8ae23587e95b05036c /app-arch
parentapp-arch/xarchiver: Clean old up (diff)
downloadgentoo-1d4dc993580b6b744c5889e594bb89d5523854c7.tar.gz
gentoo-1d4dc993580b6b744c5889e594bb89d5523854c7.tar.bz2
gentoo-1d4dc993580b6b744c5889e594bb89d5523854c7.zip
app-arch/xarchiver: Bump to 0.5.4.12
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.12.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 68a66847ab8c..6a05708e0612 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1,2 +1,3 @@
DIST xarchiver-0.5.4.11_p20170629.tar.gz 1052723 SHA256 2dabd6f5d96c5d886d9a5ed7d299cfc43d1fef88be37d1d298a78c4c01a63b45 SHA512 e63e9ddd98c5ec5708b74e993cb1901835c133e220ba95aa5a07cca01660fab5894533c57b39223db6155e2fc0ea014ce6eede853ebaf067de27f1e77c5e023f WHIRLPOOL 3516a976e6d5e161a1313d1e10d207e8344c26a0570fdd1cb1a271410bcf9ad2cab1fbce057f419e5e41833a56ff6995649a67abc47322a20f1de8f8e194035b
+DIST xarchiver-0.5.4.12.tar.gz 1074764 SHA256 62885813edce274055e8fccd3f360b61a74a3b0e4854080201638fd1f3306370 SHA512 18d177efed810576ee4dc4bc379817cbff390bcbfc541652d8288545bbb4a0e29b2136364e8675814a2780d06e2c5537ca4451a1c73a6becd45e1c0de7ba4554 WHIRLPOOL 6dbf1cb0784ef2a2a8a07c681a6a43329757c8b6cbd5f557a756cbdb53f5d8703065a141334ffddbc3fc03fce2f3acd6203615a04bb10cb3555eebc8c01256e6
DIST xarchiver-0.5.4.tar.bz2 1003045 SHA256 e63fa73979fcc56efe8cca9095fd915d31a1714ce9676246b8626f164e452ef4 SHA512 3b767c2601d94104e2fc72aa8d168afa5a154b5747a9b0518d1c348417e56e4c19d872a0029fb78decc897e0f3bc9573e17d0317b85f584e7275b0e519f5f30d WHIRLPOOL 3f5a277b05147daf29db0be26718ed51fa0bb6d2416ee41cdd8ce6c54bc66064fc5f313af39a32b428997f906c9fd4d1a0b8d60fe5d2d867b1137960b0cbe4d1
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.12.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.12.ebuild
new file mode 100644
index 000000000000..9cca9271d933
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2:=
+ x11-libs/gtk+:3="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ sed -e '/COPYING/d' -e '/NEWS/d' -i doc/Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/unarj app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}