summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-18 00:38:25 +0100
committerSam James <sam@gentoo.org>2022-10-18 00:39:36 +0100
commit1cc9cb4c6e2e6eacefeb33da4cb3eff53973cfbd (patch)
tree0996f22ec5575ff21d8313007338ed0fd0bf185a /app-arch
parentsys-apps/xdg-dbus-proxy: add github upstream metadata (diff)
downloadgentoo-1cc9cb4c6e2e6eacefeb33da4cb3eff53973cfbd.tar.gz
gentoo-1cc9cb4c6e2e6eacefeb33da4cb3eff53973cfbd.tar.bz2
gentoo-1cc9cb4c6e2e6eacefeb33da4cb3eff53973cfbd.zip
app-arch/pixz: install man page
Closes: https://bugs.gentoo.org/822732 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pixz/pixz-1.0.7-r1.ebuild (renamed from app-arch/pixz/pixz-1.0.7.ebuild)15
-rw-r--r--app-arch/pixz/pixz-9999.ebuild17
2 files changed, 21 insertions, 11 deletions
diff --git a/app-arch/pixz/pixz-1.0.7.ebuild b/app-arch/pixz/pixz-1.0.7-r1.ebuild
index 7882044a1cad..4cee8e634c94 100644
--- a/app-arch/pixz/pixz-1.0.7.ebuild
+++ b/app-arch/pixz/pixz-1.0.7-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
inherit git-r3 autotools
else
@@ -27,25 +27,30 @@ LIB_DEPEND="
RDEPEND="
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
static? ( ${LIB_DEPEND} )
"
-[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc"
+[[ ${PV} == 9999 ]] && BDEPEND+=" app-text/asciidoc"
src_prepare() {
default
+
[[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {
use static && append-ldflags -static
append-flags -std=gnu99
+
# Workaround silly logic that breaks cross-compiles.
# https://github.com/vasi/pixz/issues/67
export ac_cv_file_src_pixz_1=$([[ -f src/pixz.1 ]] && echo yes || echo no)
econf
}
-src_test() {
- emake check
+src_install() {
+ default
+
+ [[ ${PV} == "9999" ]] || doman src/pixz.1
}
diff --git a/app-arch/pixz/pixz-9999.ebuild b/app-arch/pixz/pixz-9999.ebuild
index b3f2858f5bbc..ab96d59609c4 100644
--- a/app-arch/pixz/pixz-9999.ebuild
+++ b/app-arch/pixz/pixz-9999.ebuild
@@ -5,12 +5,12 @@ EAPI=7
inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
inherit git-r3 autotools
else
SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Parallel Indexed XZ compressor"
@@ -27,25 +27,30 @@ LIB_DEPEND="
RDEPEND="
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
static? ( ${LIB_DEPEND} )
"
-[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc"
+[[ ${PV} == 9999 ]] && BDEPEND+=" app-text/asciidoc"
src_prepare() {
default
+
[[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {
use static && append-ldflags -static
append-flags -std=gnu99
+
# Workaround silly logic that breaks cross-compiles.
# https://github.com/vasi/pixz/issues/67
export ac_cv_file_src_pixz_1=$([[ -f src/pixz.1 ]] && echo yes || echo no)
econf
}
-src_test() {
- emake check
+src_install() {
+ default
+
+ [[ ${PV} == "9999" ]] || doman src/pixz.1
}