summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:08:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:33 +0200
commitb0fc4fd0abf56727805e907d1dff8cb879e4e4f0 (patch)
tree43bd01bdf770ca5d2e91aeb00865a261125e9d5b /app-arch/xarchiver
parentdev-lua/luasocket: Stabilize 3.1.0 amd64, #867379 (diff)
downloadgentoo-b0fc4fd0abf56727805e907d1dff8cb879e4e4f0.tar.gz
gentoo-b0fc4fd0abf56727805e907d1dff8cb879e4e4f0.tar.bz2
gentoo-b0fc4fd0abf56727805e907d1dff8cb879e4e4f0.zip
app-arch/xarchiver: Bump to 0.5.4.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.19.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index a739053ee944..ac31b4f123f8 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1 +1,2 @@
DIST xarchiver-0.5.4.18.tar.gz 1112838 BLAKE2B baeab65c9f81eecf070185fb3718b3e8a460e94393dfcdf38ad8bfb2a771c6f98a8638a28c43aa99d05a95772ca7e1546d9be1b602e22a715d5827350976f9d8 SHA512 a33236839d325a2d706fd0a9e2257ab5289895b030450b2060da856c047e5676ac5686312f8d00d3f38d329d0cf39fb22330a7c902b3ff5943856801435f6970
+DIST xarchiver-0.5.4.19.tar.gz 1120885 BLAKE2B 4b8b9e188b16b799f33a1816a5f19a0f67720369282239e3a22af8588b9776ee37dbc63cb1b42a426c515a360aeb1abda84b22e783bd8e4e3578eb2f2fb66ab6 SHA512 f35846bcb1236957d4201980eb1c9e49e16472ab2316935c9f8c94a9b4c3c2da879cd2730c3413041098042251607432f6af1cbacadd97b81efb81180fa5ee6a
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.19.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.19.ebuild
new file mode 100644
index 000000000000..33b845196bd5
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.19.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver/"
+SRC_URI="
+ https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ >=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}