summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:17:26 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:17:26 +0100
commit2958d5a4273938e813d7815349e23cab33585651 (patch)
treeb6a81a1dad0a17545fe5cef233a0adbe97a1452b /app-arch/wimlib
parentapp-admin/cgmanager: disable static libs (diff)
downloadgentoo-2958d5a4273938e813d7815349e23cab33585651.tar.gz
gentoo-2958d5a4273938e813d7815349e23cab33585651.tar.bz2
gentoo-2958d5a4273938e813d7815349e23cab33585651.zip
app-arch/wimlib: disable static libs
Closes: https://bugs.gentoo.org/726396 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/wimlib')
-rw-r--r--app-arch/wimlib/wimlib-1.12.0.ebuild8
-rw-r--r--app-arch/wimlib/wimlib-1.13.0.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/app-arch/wimlib/wimlib-1.12.0.ebuild b/app-arch/wimlib/wimlib-1.12.0.ebuild
index c8a393c40055..3fb8e91ab6c9 100644
--- a/app-arch/wimlib/wimlib-1.12.0.ebuild
+++ b/app-arch/wimlib/wimlib-1.12.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -55,6 +55,7 @@ src_configure() {
$(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
$(use_with openssl libcrypto)
$(use_enable threads multithreaded-compression)
+ --disable-static
)
has test ${FEATURES} && myeconfargs+=( --enable-test-support )
ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
@@ -65,3 +66,8 @@ src_compile() {
emake
pax-mark m "${S}"/.libs/wimlib-imagex
}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-arch/wimlib/wimlib-1.13.0.ebuild b/app-arch/wimlib/wimlib-1.13.0.ebuild
index c8a393c40055..3fb8e91ab6c9 100644
--- a/app-arch/wimlib/wimlib-1.13.0.ebuild
+++ b/app-arch/wimlib/wimlib-1.13.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -55,6 +55,7 @@ src_configure() {
$(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
$(use_with openssl libcrypto)
$(use_enable threads multithreaded-compression)
+ --disable-static
)
has test ${FEATURES} && myeconfargs+=( --enable-test-support )
ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
@@ -65,3 +66,8 @@ src_compile() {
emake
pax-mark m "${S}"/.libs/wimlib-imagex
}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}