summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/unshield
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/unshield')
-rw-r--r--app-arch/unshield/Manifest1
-rw-r--r--app-arch/unshield/files/unshield-bootstrap.patch32
-rw-r--r--app-arch/unshield/metadata.xml12
-rw-r--r--app-arch/unshield/unshield-0.6_p20120308.ebuild39
4 files changed, 84 insertions, 0 deletions
diff --git a/app-arch/unshield/Manifest b/app-arch/unshield/Manifest
new file mode 100644
index 000000000000..cb5bc6c21b57
--- /dev/null
+++ b/app-arch/unshield/Manifest
@@ -0,0 +1 @@
+DIST unshield-0.6_p20120308.tar.xz 31924 SHA256 5f857a496ff54b9e1121b8ce2ceaba78133e91e254203e81340010ee05224da6 SHA512 7eec3c401af4c43f599e1b1abae3efdc6b91bd132a86b6658656bec4f00040eed2b0addede7b555953ecc7b1c976fa03013820a25a68a226cf1b973caffb25c4 WHIRLPOOL 12d307b8345b604d10c42b52c28e1eb4eb9745a7b542da188b2a24c4a993b45cfd98a01740f3f30362c9b2714ba61d5e4c6f66a26e599356b5cef5b76130fc34
diff --git a/app-arch/unshield/files/unshield-bootstrap.patch b/app-arch/unshield/files/unshield-bootstrap.patch
new file mode 100644
index 000000000000..565b9e520f5c
--- /dev/null
+++ b/app-arch/unshield/files/unshield-bootstrap.patch
@@ -0,0 +1,32 @@
+This is replaced by `AT_M4DIR=m4 eautoreconf` in the ebuild.
+
+--- bootstrap
++++ bootstrap
+@@ -26,17 +26,17 @@
+ INCLUDES="-I m4"
+ fi
+ set -x
+-aclocal $INCLUDES
+-autoheader
++# aclocal $INCLUDES
++# autoheader
+
+ # Check For OSX
+ # rhcp011235@gmail.com
+
+-KERNEL_NAME=`uname -s`
+-if [ "$KERNEL_NAME" = "Darwin" ]; then
+- glibtoolize --copy --automake
+-else
+- libtoolize --copy --automake
+-fi
+-automake --copy --foreign --add-missing
+-autoconf
++# KERNEL_NAME=`uname -s`
++# if [ "$KERNEL_NAME" = "Darwin" ]; then
++# glibtoolize --copy --automake
++# else
++# libtoolize --copy --automake
++# fi
++# automake --copy --foreign --add-missing
++# autoconf
diff --git a/app-arch/unshield/metadata.xml b/app-arch/unshield/metadata.xml
new file mode 100644
index 000000000000..1e9221eec842
--- /dev/null
+++ b/app-arch/unshield/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">twogood/unshield</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/unshield/unshield-0.6_p20120308.ebuild b/app-arch/unshield/unshield-0.6_p20120308.ebuild
new file mode 100644
index 000000000000..781cc978e7e5
--- /dev/null
+++ b/app-arch/unshield/unshield-0.6_p20120308.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="http://github.com/twogood/unshield http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/openssl:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-bootstrap.patch
+ ./bootstrap
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467548
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-ssl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}