summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-01-25 21:09:41 +0100
committerFabian Groffen <grobian@gentoo.org>2022-01-25 21:13:44 +0100
commit7f770c6e42a8e6c1bed10ee17064d35813302018 (patch)
treeef958cd74bc42ef4618ec4ee5c9ce08e0f0263a8 /app-arch/pxz/pxz-5.0_pre20151029.ebuild
parentdev-ml/ppx_js_style: 0.14.1 bump. ocaml 4-13 ready (diff)
downloadgentoo-7f770c6e42a8e6c1bed10ee17064d35813302018.tar.gz
gentoo-7f770c6e42a8e6c1bed10ee17064d35813302018.tar.bz2
gentoo-7f770c6e42a8e6c1bed10ee17064d35813302018.zip
app-arch/pxz: fix for musl
Closes: https://bugs.gentoo.org/717062 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-arch/pxz/pxz-5.0_pre20151029.ebuild')
-rw-r--r--app-arch/pxz/pxz-5.0_pre20151029.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-arch/pxz/pxz-5.0_pre20151029.ebuild b/app-arch/pxz/pxz-5.0_pre20151029.ebuild
index 1ae6092ecb65..64175e6452fa 100644
--- a/app-arch/pxz/pxz-5.0_pre20151029.ebuild
+++ b/app-arch/pxz/pxz-5.0_pre20151029.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/jnovy/pxz/archive/fcfea93957d96b7661d1439cf4b767ecfd
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux"
IUSE=""
# needs the library from xz-utils
@@ -26,4 +26,8 @@ src_prepare() {
export BINDIR="${EPREFIX}"/usr/bin
export MANDIR="${EPREFIX}"/usr/share/man
default_src_prepare
+
+ if use elibc_musl ; then
+ sed -i -e '/<error.h>/c\#define error(R,E,S,...) fprintf(stderr, S "\\n", ##__VA_ARGS__); exit(R)' pxz.c
+ fi
}