summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-02 02:29:49 +0000
committerSam James <sam@gentoo.org>2022-03-02 02:31:03 +0000
commit61c003d081de7195408fb32386a7afdf4ec8b5b2 (patch)
tree86ec1e8a8498f2ff900c2b91739af27bb2cb58e6 /app-arch/lrzip
parentx11-misc/xscreensaver: add 6.03 (diff)
downloadgentoo-61c003d081de7195408fb32386a7afdf4ec8b5b2.tar.gz
gentoo-61c003d081de7195408fb32386a7afdf4ec8b5b2.tar.bz2
gentoo-61c003d081de7195408fb32386a7afdf4ec8b5b2.zip
app-arch/lrzip: add 0.650
Bug: https://bugs.gentoo.org/834456 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/lrzip')
-rw-r--r--app-arch/lrzip/Manifest1
-rw-r--r--app-arch/lrzip/lrzip-0.650.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
index 82812d245266..fda21f1f62bf 100644
--- a/app-arch/lrzip/Manifest
+++ b/app-arch/lrzip/Manifest
@@ -1 +1,2 @@
DIST lrzip-0.641.tar.gz 262761 BLAKE2B 5a81d9ca8b40c141c90488e9ffcd1dfd5bef3fe7cf9b02c00b9382cd902ef8cd891401f21c9cdd5d5750daf639c05a1e6f1f010fcbf42a9cdaa4f11921fac783 SHA512 cb14dda15485faa24cb840dd94ecd4741bd47464770ae8b27f97b5c263d8a32e40ceb17b288f0f70426598ef2acf84b091593fc8cf7a0f2db0abde88d09a301f
+DIST lrzip-0.650.tar.gz 238952 BLAKE2B 5013de6f8948aebf1bb7545c392b623a1628f74298cab3316555ec6a1acbbc64f81abcf1f5c8a7a67a547d8748f7bb05d0d88cb58b6fa3ab765baad596acb756 SHA512 30a3217703748f6894fbac438976e3179a46e3f6af59e5849f7f8460d1a094275a4b41790617f4bd1ae7c7476548d2daadcfab9ab60c167ce5c24cd593e70964
diff --git a/app-arch/lrzip/lrzip-0.650.ebuild b/app-arch/lrzip/lrzip-0.650.ebuild
new file mode 100644
index 000000000000..9cb8ed8b2d4e
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.650.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="https://github.com/ckolivas/lrzip"
+SRC_URI="https://github.com/ckolivas/lrzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="app-arch/bzip2
+ app-arch/lz4
+ dev-libs/lzo
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-perl/Pod-Parser
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # ASM optimizations are only available on amd64 and x86, bug #829003
+ local asm=no
+ if use amd64 || use x86; then
+ asm=yes
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ --enable-asm=${asm}
+}
+
+src_install() {
+ default
+ # Don't collide with net-dialup/lrzsz and /usr/bin/lrz, bug #588206
+ rm -f "${ED}"/usr/bin/lrz || die
+ rm -f "${ED}"/usr/share/man/man1/lrz.* || die
+
+ find "${ED}" -name '*.la' -delete || die
+}