summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/gzip/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/gzip/files')
-rw-r--r--app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch11
-rw-r--r--app-arch/gzip/files/gzip-1.4-asmv.patch30
-rw-r--r--app-arch/gzip/files/gzip-1.4-assembler.patch52
-rw-r--r--app-arch/gzip/files/gzip-1.4-no-gets.patch22
4 files changed, 115 insertions, 0 deletions
diff --git a/app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch b/app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch
new file mode 100644
index 000000000000..8d92b609b5dd
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch
@@ -0,0 +1,11 @@
+--- Makefile.in
++++ Makefile.in
+@@ -926,7 +926,7 @@
+ rm -f "$$dest" && \
+ case $@ in \
+ install-exec-hook) \
+- ln "$$source" "$$dest" || $(LN_S) "$$source" "$$dest";; \
++ $(LN_S) "$$source" "$$dest";; \
+ esac \
+ ) || exit; \
+ done; \
diff --git a/app-arch/gzip/files/gzip-1.4-asmv.patch b/app-arch/gzip/files/gzip-1.4-asmv.patch
new file mode 100644
index 000000000000..c87855018cff
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.4-asmv.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/show_bug.cgi?id=302773
+
+--- tailor.h.old 2010-01-29 11:13:02.000000000 +0000
++++ tailor.h 2010-01-29 13:18:15.000000000 +0000
+@@ -69,9 +69,6 @@
+ # include <io.h>
+ # define OS_CODE 0x00
+ # define SET_BINARY_MODE(fd) setmode(fd, O_BINARY)
+-# if !defined(NO_ASM) && !defined(ASMV)
+-# define ASMV
+-# endif
+ #else
+ # define near
+ #endif
+@@ -182,7 +179,6 @@
+ # define PATH_SEP2 ':'
+ # define STDC_HEADERS
+ # define OS_CODE 0x01
+-# define ASMV
+ # ifdef __GNUC__
+ # define HAVE_DIRENT_H
+ # define HAVE_FCNTL_H
+@@ -201,7 +197,6 @@
+ #endif
+
+ #if defined(ATARI) || defined(atarist)
+-# define ASMV
+ # define OS_CODE 0x05
+ # ifdef TOSFS
+ # define PATH_SEP2 '\\'
diff --git a/app-arch/gzip/files/gzip-1.4-assembler.patch b/app-arch/gzip/files/gzip-1.4-assembler.patch
new file mode 100644
index 000000000000..76aade5c9341
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.4-assembler.patch
@@ -0,0 +1,52 @@
+http://bugs.gentoo.org/309079
+http://lists.gnu.org/archive/html/bug-gzip/2010-02/msg00032.html
+
+From 61af16213a488af3a8e994399ebd0859d390edb6 Mon Sep 17 00:00:00 2001
+From: Jim Meyering <meyering@redhat.com>
+Date: Sat, 20 Mar 2010 13:05:58 +0100
+Subject: [PATCH] use assembly code matcher when possible
+
+* configure.ac (ASCPPPOST): Backslash-escape "#" in AC_SUBST'd
+variable, to keep make from seeing it as a comment-introducer.
+Based on a patch by Petr Pisar.
+* lib/Makefile.am (match.$(OBJEXT)): Use AM_V_GEN and AM_V_at.
+* lib/match.c: Don't include <config.h>.
+It would impede configure-time assembler test.
+* .x-sc_require_config_h: Exempt lib/match.c from syntax-check.
+* .x-sc_require_config_h_first: Likewise.
+---
+ .x-sc_require_config_h | 1 +
+ .x-sc_require_config_h_first | 1 +
+ THANKS | 1 +
+ configure.ac | 2 +-
+ lib/Makefile.am | 12 ++++++------
+ lib/match.c | 2 --
+ 6 files changed, 10 insertions(+), 9 deletions(-)
+ create mode 100644 .x-sc_require_config_h
+ create mode 100644 .x-sc_require_config_h_first
+
+--- a/configure
++++ b/configure
+@@ -22588,5 +22588,5 @@
+
+ # cc -E produces incorrect asm files on SVR4, so postprocess it.
+-ASCPPPOST="sed '/^ *#/d; s,//.*,,; s/% /%/g; s/\\. /./g'"
++ASCPPPOST="sed '/^ *\\#/d; s,//.*,,; s/% /%/g; s/\\. /./g'"
+
+
+diff --git a/lib/match.c b/lib/match.c
+index 4ef6128..5dd8d64 100644
+--- a/lib/match.c
++++ b/lib/match.c
+@@ -28,8 +28,6 @@
+ * David Mosberger-Tang <davidm@hpl.hp.com>.
+ */
+
+-#include <config.h>
+-
+ /* Preprocess with -DNO_UNDERLINE if your C compiler does not prefix
+ * external symbols with an underline character '_'.
+ */
+--
+1.7.1.1
+
diff --git a/app-arch/gzip/files/gzip-1.4-no-gets.patch b/app-arch/gzip/files/gzip-1.4-no-gets.patch
new file mode 100644
index 000000000000..6da6e64bb7fd
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.4-no-gets.patch
@@ -0,0 +1,22 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@