summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-06 01:08:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-06 02:30:14 +0200
commitc71965df848b77ec5725d2db7192efffc6c6708e (patch)
treeb1bcdceda7fbb538351d4025686721ace454f5e5 /app-arch/bzip3
parentapp-crypt/certbot-nginx: add 1.31.0 (diff)
downloadgentoo-c71965df848b77ec5725d2db7192efffc6c6708e.tar.gz
gentoo-c71965df848b77ec5725d2db7192efffc6c6708e.tar.bz2
gentoo-c71965df848b77ec5725d2db7192efffc6c6708e.zip
app-arch/bzip3: bump to 1.1.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.1.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index d416b2f9b4da..3cb8d3ad9acd 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1,3 +1,4 @@
DIST bzip3-1.1.3.tar.xz 257212 BLAKE2B cc94b4c2caa3123b2c775d66143757bcaea7ead6d8a130391d6714583cfcb92fffca47ad80ffc8b5a01483f6cbfab7101c96521cd97e740116c9e10c64c358e8 SHA512 d48695d066ddc79e81c189f8c06e999f8eb8191982db8908f7bd4dfaa0f8fab1ba57e41664962cc6e8611f8398603918e4bd4d58efff2f04292ea54983a6f38d
DIST bzip3-1.1.4.tar.xz 260404 BLAKE2B ddd087b631c9d5945dea0f4da280dfd74fd303eaed10f7553f770ca18b3b65f00718c073d87e565602a9ed02f4604a0d2dda0ff42cbd38f593bb012f5362cc5c SHA512 86f26b290001d255ad1d2378b5e2d59f9c85e1625ba5d7dca86acd544bb80af95b3379c215a03e0f81f77b7972a852d37746c1028464f404d28a6f9b707383b8
DIST bzip3-1.1.5.tar.xz 265340 BLAKE2B 0226a97d564f1c9d9d1089b43ae79a9e43d0b77628298ef953c45505ad8d62caaf17bf6fa357857f123cf072b8ccd3003bfe138f25284baa5a5a5cdd8a555f71 SHA512 589c2e8e675a61014c7c4e82d0f2067201e3fb97bf7cfa6b7aa23690dc739824226089ac710509cc085b22eeb671ed5e23c6493967a433d3b284cb638af71be8
+DIST bzip3-1.1.6.tar.xz 265708 BLAKE2B 9429dcb3e9deef8aafdf890215ba95669dbcb135d6d2896f18cc70b482bab321497d3a26f36be59700ad0da879578b7c906f20629c72642aa15fc3b1507a788a SHA512 19120d3a850495a5bcc43b124e4a8eddf41bac55119d0898bf1e7c5b744f4bcc84c41b9018615f577fe3bfdceab8dd2ab6f2722cb9fbf86bf1c0a2da9ca32916
diff --git a/app-arch/bzip3/bzip3-1.1.6.ebuild b/app-arch/bzip3/bzip3-1.1.6.ebuild
new file mode 100644
index 000000000000..0d9329da48ca
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}