summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-20 14:23:25 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-20 14:37:04 +0200
commita5e186b4dc7d549452fda0af7ee20528b54f7d81 (patch)
tree29cb46790266f833fba35e7a50ce3c60162810ae /app-arch/bzip3
parentwww-client/vivaldi: Drop old 6.0.2979.15-r1 (diff)
downloadgentoo-a5e186b4dc7d549452fda0af7ee20528b54f7d81.tar.gz
gentoo-a5e186b4dc7d549452fda0af7ee20528b54f7d81.tar.bz2
gentoo-a5e186b4dc7d549452fda0af7ee20528b54f7d81.zip
app-arch/bzip3: bump to 1.3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.3.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index b55f973442ca..5ca516b923d6 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1 +1,2 @@
DIST bzip3-1.3.0.tar.xz 276724 BLAKE2B 4b9ddd4da193cc784265eb2584804cfe7ddb55947634dab9068f7df8d0f7ee8684b3ce1cc50df355780aa8514462d23e93ff637ce2ca552f3d09b32bf1edcde2 SHA512 3777f6f0c337b5014b510c97ca3d19c77e7e474482d9e83143186ab593967fcec3e19163b32b03e6d8243838091f24e45eca245e35f0a6e5e713f29873ad62c4
+DIST bzip3-1.3.1.tar.xz 277248 BLAKE2B 37044fae19a2743d2e5bd48c65f034578ccd30c316d9c19c0c8786f1248babe1dcb942cc18d3a65e0756210b551af8c7a15a1675d98dbd77d4832beff0598a9a SHA512 41616eaa53422eb5bb8780db731ecd0371599e688622810be5d1fac04aa489d212db3273a5f0d15702507c8c92b36e9a4006c52bc67da7ac6ce41c73ff412e51
diff --git a/app-arch/bzip3/bzip3-1.3.1.ebuild b/app-arch/bzip3/bzip3-1.3.1.ebuild
new file mode 100644
index 000000000000..33aa6e59599d
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}