summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-07 12:48:56 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-07 13:31:34 +0200
commit45930bfb6dac4bd9755b1fd21461bd7cf82e86eb (patch)
treeadb462fa8d8757255e3b9bb27b5aee822f77b877 /app-arch/bzip3
parentwww-client/chromium: drop 115.0.5790.102 (diff)
downloadgentoo-45930bfb6dac4bd9755b1fd21461bd7cf82e86eb.tar.gz
gentoo-45930bfb6dac4bd9755b1fd21461bd7cf82e86eb.tar.bz2
gentoo-45930bfb6dac4bd9755b1fd21461bd7cf82e86eb.zip
app-arch/bzip3: bump to 1.3.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.3.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index 94afaccaccc9..ab96b9457091 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1 +1,2 @@
DIST bzip3-1.3.1.tar.xz 277248 BLAKE2B 37044fae19a2743d2e5bd48c65f034578ccd30c316d9c19c0c8786f1248babe1dcb942cc18d3a65e0756210b551af8c7a15a1675d98dbd77d4832beff0598a9a SHA512 41616eaa53422eb5bb8780db731ecd0371599e688622810be5d1fac04aa489d212db3273a5f0d15702507c8c92b36e9a4006c52bc67da7ac6ce41c73ff412e51
+DIST bzip3-1.3.2.tar.xz 277768 BLAKE2B 6ee7e5d7f1ab11c19664937fc631e51f5707b6893441bdd6e1beb52e9e2e46255e31c782f61939eba3f966f2be74b422a89f5fcd9d3f42caea07784f2f858efd SHA512 76521377adfe737b30e77f5c3241c1c12214165492fba5acbc5ba09c8e7b91396b772f9fec936d6603413c3ef179a13597b13509df99bd8a2d56cbf14a70a84f
diff --git a/app-arch/bzip3/bzip3-1.3.2.ebuild b/app-arch/bzip3/bzip3-1.3.2.ebuild
new file mode 100644
index 000000000000..33aa6e59599d
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}