summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2023-02-26 17:49:47 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-03-07 09:46:50 +0200
commitf616a094ad8f26577a7204f9b4de685892679da7 (patch)
treefc1b4f8d78b385e4e5323977b4f10a7905c440bb /app-admin
parentmedia-fonts/iosevka: update EAPI 7 -> 8 (diff)
downloadgentoo-f616a094ad8f26577a7204f9b4de685892679da7.tar.gz
gentoo-f616a094ad8f26577a7204f9b4de685892679da7.tar.bz2
gentoo-f616a094ad8f26577a7204f9b4de685892679da7.zip
app-admin/pwman3: add 0.12.2
Closes: https://bugs.gentoo.org/896476 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29810 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pwman3/Manifest1
-rw-r--r--app-admin/pwman3/pwman3-0.12.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/pwman3/Manifest b/app-admin/pwman3/Manifest
index 45f878ee43d8..29a35022f5d4 100644
--- a/app-admin/pwman3/Manifest
+++ b/app-admin/pwman3/Manifest
@@ -1 +1,2 @@
DIST pwman3-0.11.1.tar.gz 76992 BLAKE2B cd7289781436f0f8b941d587c61b2d8a5cad52f3d57d01106d73b3da5930de2bd2df15fe5a4bcfbdce5e5733b7328764d6e4e2d18cba8a575cadad8835218e75 SHA512 111713e23b64a7492b5e2735b0d0117a81759bd9f25a87327a2aa4a465fbbc8a0aa0fbfa86b84cbcd40eb1540d05cdbc6fb81982fe61953df91979e674ce5640
+DIST pwman3-0.12.2.tar.gz 76744 BLAKE2B 5223169a267f0c35bcb26499138c9b768c6e29c4ce39d4fb89c56eb72d24a9729159bed93af24e12f1e0e6c1569586772eb36954afd51afc7c97c9de898346e5 SHA512 587839e7d532ef3c53e2c429b086eb6bd59290ce43687034400f8e0772cc4e97c9296694ad83c5fa3fdde37b8d8fef5bc150e9f81fcb9fe8712ffafb4be8b400
diff --git a/app-admin/pwman3/pwman3-0.12.2.ebuild b/app-admin/pwman3/pwman3-0.12.2.ebuild
new file mode 100644
index 000000000000..cac81b170b12
--- /dev/null
+++ b/app-admin/pwman3/pwman3-0.12.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A lightweight password-manager with multiple database backends"
+HOMEPAGE="https://pwman3.github.io/pwman3/"
+SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/pexpect[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+pkg_postinst() {
+ optfeature "Support for mongodb" dev-python/pymongo
+ optfeature "Support for postgresql" dev-python/psycopg:2
+ optfeature "Support for mysql" dev-python/pymysql
+}