summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-12-06 15:01:36 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-12-06 15:01:36 -0600
commite5934171bfc6e10cc3574070fa9177a69a496b08 (patch)
tree7702ce94b6d862a28a33541ae0a462d8ff726d2e /app-admin
parentapp-admin/ansible-core: add 2.13.7 (diff)
downloadgentoo-e5934171bfc6e10cc3574070fa9177a69a496b08.tar.gz
gentoo-e5934171bfc6e10cc3574070fa9177a69a496b08.tar.bz2
gentoo-e5934171bfc6e10cc3574070fa9177a69a496b08.zip
app-admin/ansible: add 6.7.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-6.7.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 45fe5659eac8..fb3ca72855fe 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -2,3 +2,4 @@ DIST ansible-4.6.0.tar.gz 35644507 BLAKE2B 94f544caa81ba7d20493f469483612f2ebf9e
DIST ansible-5.10.0.tar.gz 36898833 BLAKE2B 5705325c150909e4911cbc6fafb9b6194bcd15cf7a97978835b29cb8b87b671fa888163e28e825d1fc98006c57313677afed63236f4a55af415a70daf5fe305f SHA512 d81b34642533dfaf0c3dba5ecc8ba483efb3d82bd40afa469de2778666e932bec3c20e61ae579184fcbd7f1ec7c8d694617f334ebb3e910db3c9f6709d3b9385
DIST ansible-6.5.0.tar.gz 38275680 BLAKE2B 5d17ba2b8b3a0ccb1ea9873c0d500ca7984d2d3db19d062807004da5c001ee44d33cd6707226887bef8f6bae0ea9584f8c2c63a8cb176a2244b3b2ad92e13454 SHA512 ddb77304c6a9617186fa0252a0da91632ffc21f910e02fc68e340ed37de0806586a2543700e996db7fb0bb9240a2ee20b7a462f005de200028748b38fbb2e293
DIST ansible-6.6.0.tar.gz 35620748 BLAKE2B 1e36ff72669902629cf1f373e9816b9d0a3136cb205867a24d67efc27b0ca3f2d361f3017fb1543c46da8693bb165ee6b354388611ab3e3186098513bd49f41d SHA512 51d06386dfb14ef826562dd4991556805d3e6014173965f0541e97b905984208a95889392dd3bb22027060ac767a354d53dfb9de774d5b461b15b236395d6fd1
+DIST ansible-6.7.0.tar.gz 36371372 BLAKE2B 75cb14f158c36ded8313a1c5b798838afdf3a38ffc8e29a87c8e1e3e74c9aeca827432397ad83ed23a1d3aeaaef91822cc3c23aa226a307d93f84f54b25d71bb SHA512 676baf03626d5bf36aea7117d39ef71ba7878ab6bccdec1ee199bd699d559a5f3f6a0d9032ef120204093677b7fbbe1b575529d3aa692acd1a4447f9c2715f3a
diff --git a/app-admin/ansible/ansible-6.7.0.ebuild b/app-admin/ansible/ansible-6.7.0.ebuild
new file mode 100644
index 000000000000..cf0da827da5f
--- /dev/null
+++ b/app-admin/ansible/ansible-6.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.13.0
+ <app-admin/ansible-core-2.14"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}