summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-07-20 10:29:03 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-07-20 10:29:50 -0700
commit74a613d51782ffe523d0a6cdd772dfc4a1659284 (patch)
tree461fe62680d0352e8535c400c663bc09e6cc1e02 /app-admin
parentdev-ruby/facter: fix vague Gem::MissingSpecError (diff)
downloadgentoo-74a613d51782ffe523d0a6cdd772dfc4a1659284.tar.gz
gentoo-74a613d51782ffe523d0a6cdd772dfc4a1659284.tar.bz2
gentoo-74a613d51782ffe523d0a6cdd772dfc4a1659284.zip
app-admin/puppet-lint: bump to 4.2.4
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-lint/Manifest1
-rw-r--r--app-admin/puppet-lint/puppet-lint-4.2.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
index 32345ea1c4f3..4c98387cef43 100644
--- a/app-admin/puppet-lint/Manifest
+++ b/app-admin/puppet-lint/Manifest
@@ -2,3 +2,4 @@ DIST puppet-lint-4.2.1.gem 81920 BLAKE2B 5e291e4c1743092be9935231280f04ce3affdc1
DIST puppet-lint-4.2.2.gem 81920 BLAKE2B cad796866f323113a8c2aa5cf86b6187423f27186032ea76ebd1f158937c34f315d93de3d92b01acc0b160947b720bd987550c52aaa53a51f165396de776ec88 SHA512 e8a591e615db87dc2edc22fc4d53c03004e0227748896005d2252fab8b77193ecd30f9167702c6c4fd6551daaa0894789f3d9d50fb705eecaed4a22573a94afc
DIST puppet-lint-4.2.3-pr181-fix-warnings.patch 5601 BLAKE2B a04fdf9d8627cc888924b4282a09e076d7e029eda008fc8da138a121a21e227cff45a54ddbe770a286a2a15e43d4402526a6201c805f6e574755a11a1d13d7d7 SHA512 15638f2d4a81c969aa77b51f2f147a1fba5544dd7e52f3127dc9949afaabbd161f815a22dc5091f19d3d16bc2be97bb50f455a3a67c503aff58e737288f80e49
DIST puppet-lint-4.2.3.gem 81920 BLAKE2B ee98aaed336a4302c4d67d94c83f30f6fdfc111192b483f39a2c096f00daff2f7caf54bfa11c4b8217648a0ca68c6c8da5a4a6f2d0cab8efb6e2d7e814155780 SHA512 2f2192a48ed460371092ce99755b8cde55526ed96ee72d2a5b7989f7df7afb6abce5d3e8e7a0dca577b199bb380935e8734a92a53248697bb7195091da4cb9f6
+DIST puppet-lint-4.2.4.gem 82432 BLAKE2B 54bd65b917c184163adca920767b88d064cdd8c931d7911a64698d68a7b335055bd95bff91c462ecaf4111a231186ee5d2f2de42a04abffb519a67a4825bec59 SHA512 19b28de4e5d183dd46727cc4f7f7a6b81eb5ec7d0c7ca23514a015e43a7528bfc110853b82e65ac5da4d002abc3c21ce5d10abb6a97717b540d13570fd42eb6b
diff --git a/app-admin/puppet-lint/puppet-lint-4.2.4.ebuild b/app-admin/puppet-lint/puppet-lint-4.2.4.ebuild
new file mode 100644
index 000000000000..59d8d9af62c5
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-4.2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP="puppet-lint"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="https://github.com/puppetlabs/puppet-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCH_NAME="${PN}-4.2.3-pr181-fix-warnings.patch"
+#SRC_URI+=" https://github.com/puppetlabs/puppet-lint/pull/181.patch -> ${PATCH_NAME} "
+
+#PATCHES=(
+# "${DISTDIR}/${PATCH_NAME}"
+#)
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ # Skip acceptance tests due to unpackages puppet_litmus which in turn
+ # has a number of unpackaged dependencies.
+ rm -rf spec/acceptance || die
+ rm -f spec/spec_helper_acceptance.rb || die
+}