summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:07:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:20 +0200
commit45db566c3772664328d57d4788360cb7b59d4398 (patch)
treec9ca694e1366019a207c2d6467ba4082fa20deb6 /app-admin
parentdev-python/boto3: Bump to 1.22.13 (diff)
downloadgentoo-45db566c3772664328d57d4788360cb7b59d4398.tar.gz
gentoo-45db566c3772664328d57d4788360cb7b59d4398.tar.bz2
gentoo-45db566c3772664328d57d4788360cb7b59d4398.zip
app-admin/awscli: Bump to 1.23.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.23.13.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b6aeaf0458ab..d523cdceaaeb 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,6 +1,7 @@
DIST aws-cli-1.23.10.gh.tar.gz 2204515 BLAKE2B 562bede8252647a3f21ac4b7c88d54107a3e613edadfd478545f1ef5cf7641f74c4df27cfc97e86c05a8a140b5bb49e743a2904ac994779c925814565ea5172b SHA512 6ff7ef9ee202e675faf84b55a7b2f5b21b8150485ed50bd511bb5326532cc5f8589520575bc59ab0e3a9ee49356c82c7406afb86233d28f3f5efe1a65270679c
DIST aws-cli-1.23.11.gh.tar.gz 2204964 BLAKE2B f3708e7a554727339607ad073ef4f67eaeb47146e03e6c974a3c748cf5937f7314ff8174f74c71519031d0ee9c7ee598be6747265681c5c5f847014940741949 SHA512 500dee52aa407bfbe4fba366010e68aad6ca5fd64d0acfb0089b44cababbbca57c282e084e3ef9e03107c92793ff89237a28fd6337b82d97efb042445abf8767
DIST aws-cli-1.23.12.gh.tar.gz 2205163 BLAKE2B 27dcd4580de6af921475435c2ca080179ac9d6687a4c5ba445049b5c501d868ca7cc67421a1faef6fd36fd7786ba8593818007dcb46ed6cfb1c5a57ba0b1c438 SHA512 f268d12f5f52d6a7250ca758ab916ba6618d8a7e95033a45b23aee2d499572af27df5a0ba7c2ba92592afd68217f429e3a49862feb7a3c57f7e3fc9701f2abc2
+DIST aws-cli-1.23.13.gh.tar.gz 2206225 BLAKE2B 185702ea1a747897f07d5f6eaab817283647ba0b3beb01018b8d342f09c5371faa80211c8399ca8c813b4405117f32b635b5959008ad7fa3e3372a3c52447734 SHA512 5b9876f40dff434a92dbec1222e25874ee38564e997bde9b7612639cfad763cc7a4005a3aa74a03392713e38421de2fe2bd5610f8c26c312f3d1ff489a350c95
DIST aws-cli-1.23.4.gh.tar.gz 2200991 BLAKE2B b70012a8dd83d46a460977063ad11111a7af728ee7e00f87cf5d559ff3e1a4eb1824580bfc5f869d749d0e75e336eb3a025a77f2b637a7306dc39fadba2382a1 SHA512 e949b4bf171e1ad4364ced1fbb7bec89d83077ee2de745dfc661fe1518476e7e07a29e58877adbe65c46398602af374d9af47ae976e7984b1ed2e59a67bd4f03
DIST aws-cli-1.23.7.gh.tar.gz 2201704 BLAKE2B 4c97a7bfc09c794afebd7c770bc1dcc98a8f1458597235bdde0a8236ce49f661cff6f7ab7f4c7eee85160432c5f991b18feab45568c6b5b84aa8eff9b11b0c18 SHA512 24173c1f2905bc005c2f02de69feadf21e78e38b569f9c0dcb72658a2ca1b0c3c621bf4a6d121be2388c40fcfb02423feb301b84d63b25ea384ffe1c0ddd8d37
DIST aws-cli-1.23.8.gh.tar.gz 2201989 BLAKE2B 59651082736c71a08085eab047056d949e908a42ca0f3af15d666cb3b7e5d21d1770622d8121c366489451e51349f19324c36542f24013ede33306989840fe57 SHA512 a58ab507302fb9631983fb31d1b877f5af8856493f04e6c5c18cbb883a60247393e4ce62f1231908fc774d2f74c691086bc8e21af96524e82595489b5cf1d195
diff --git a/app-admin/awscli/awscli-1.23.13.ebuild b/app-admin/awscli/awscli-1.23.13.ebuild
new file mode 100644
index 000000000000..acabee851193
--- /dev/null
+++ b/app-admin/awscli/awscli-1.23.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}