summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-02 08:32:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-02 09:12:23 +0100
commit0e2d69eadcc039ff5362edcd54e1833caff43132 (patch)
treed7b31003c9294e0d9850da44b0d50ba65aa3caa1 /app-admin
parentdev-python/boto3: Bump to 1.20.18 (diff)
downloadgentoo-0e2d69eadcc039ff5362edcd54e1833caff43132.tar.gz
gentoo-0e2d69eadcc039ff5362edcd54e1833caff43132.tar.bz2
gentoo-0e2d69eadcc039ff5362edcd54e1833caff43132.zip
app-admin/awscli: Bump to 1.22.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.18.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 1187f70d8c53..e588ae53f88e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,4 +2,5 @@ DIST awscli-1.21.12.tar.gz 2097963 BLAKE2B e752cb1369be9ee26b517ba1226d3e16fad0a
DIST awscli-1.22.14.tar.gz 2120655 BLAKE2B ffba1bea0574830e6eb3e343b5d83a308e19b557ddde981066b93008062c0702bfba47b7ff7ddc86d4f148606cce8089e81525c54a11eef23906ef1df6303af7 SHA512 0585d8f4842b23065a14cd1f73a7ee810d705ab4d2480591ebf13b640d7501ec784fb2000cdc685cbc6c4e996b7d68763ed79d2122bd61e07a0f97822c925d12
DIST awscli-1.22.15.tar.gz 2121382 BLAKE2B 849a40f41382a8bbff235791848056791fb636bebf4e0a870804378a39d427db432dff9ede40f93cfcdb0a6d944f213040fe4ef4337e6dc778475860efb0a965 SHA512 380d79f5ecd6c728fc526f8b4384740f8b08ff704d71507dd536f650de103740814ed421132bdb78c86d4da1f05b0ed61b1ff661f15fa4617e9d96e217d07673
DIST awscli-1.22.17.tar.gz 2123827 BLAKE2B e721c09ed07afcde2026b58623ecfeafd2433dbff7beabcad46aa87659e9817613b647210799ac2c6a070c77169d815e592bed0b94441b69318c3287412aaf02 SHA512 84fd1a8f7904766cbae6180591762bd4531e88b3d404bb97198d96cb99bd89923d7c1809b5d6675f2cfcad143e64bbc05359cf9cfcad9fdc245a007a7525e2cf
+DIST awscli-1.22.18.tar.gz 2124899 BLAKE2B bf1960c9b24e0f4581e5d495e68b0c4ed69f0d0de29e77709cc9ab50dbf6099a2244d917ec5162cb30f76f30a38a8ae0477f3424a28a9d276afd46b31a8807e1 SHA512 80abf1ff0c89abf308c840856c67888f39220d05b04032f3ae8c9efeb98d6fafb67bbcce804c36515337d0e1b3c6405d7a85fd42cca59030002bb62c89f56070
DIST awscli-1.22.5.tar.gz 2111679 BLAKE2B 970e472e8de43664d060023fdab9f54ce848c5655d8aa417efeae1b1efb52989fd021817521db9dc9cd64580cabbf0c30f3d0178034bdb1edf41feebbc690f46 SHA512 9177fe9da0fb8e9e28777bbf8f2c3fe089a08851b57a49fecefab43417fff187584638d17394289bf6df3d18d9052fd958bd3fbc8064327120af04a0cbe30494
diff --git a/app-admin/awscli/awscli-1.22.18.ebuild b/app-admin/awscli/awscli-1.22.18.ebuild
new file mode 100644
index 000000000000..85073515ab9a
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.18.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}