summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-24 17:26:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-29 09:03:27 -0400
commit0d61c12173e779de87882aa5310edf83f1de4e89 (patch)
tree26f3f4f8b22fc4e5af5bb8624b9fd6bc73895134 /app-admin/ryzen_smu
parentapp-admin/ryzen_smu: add github upstream metadata (diff)
downloadgentoo-0d61c12173e779de87882aa5310edf83f1de4e89.tar.gz
gentoo-0d61c12173e779de87882aa5310edf83f1de4e89.tar.bz2
gentoo-0d61c12173e779de87882aa5310edf83f1de4e89.zip
app-admin/ryzen_smu: migrate to linux-mod-r1
I don't actually use this (no hardware), but migrating myself as an example given it's simple and cleanups the CC_IS_CLANG checks. Sorry if it breaks anything (feel free to mask or revert if need be). Haven't heard from slashbeast (maybe didn't notice PR), but hopefully this is okay. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-admin/ryzen_smu')
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild
new file mode 100644
index 000000000000..f1b8625e5b94
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://github.com/leogx9r/ryzen_smu"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ local modlist=( ryzen_smu )
+ local modargs=( KERNEL_BUILD="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ insinto /usr/lib/modules-load.d
+ doins "${FILESDIR}"/ryzen_smu.conf
+}