summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-11-14 22:19:51 +1300
committerKent Fredric <kentnl@gentoo.org>2020-11-14 22:32:49 +1300
commitb06c8cb0ab916ed51493741f76e6a5645b1ee5ad (patch)
treecdad960bf4617d2cb31adb07f6db64e2c863dc16 /app-admin/rex
parentdev-util/ccache: Stabilize 3.7.12 s390, #752225 (diff)
downloadgentoo-b06c8cb0ab916ed51493741f76e6a5645b1ee5ad.tar.gz
gentoo-b06c8cb0ab916ed51493741f76e6a5645b1ee5ad.tar.bz2
gentoo-b06c8cb0ab916ed51493741f76e6a5645b1ee5ad.zip
app-admin/rex: -9999 strip authortests w/ false-postive missing deps
These files make `dzil listdeps` report additional dependencies that aren't actually useful or needed anywhere in the build. Stripping them makes the number of complained about missing deps in einfo logs smaller Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'app-admin/rex')
-rw-r--r--app-admin/rex/rex-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-admin/rex/rex-9999.ebuild b/app-admin/rex/rex-9999.ebuild
index 6a9496d529c0..f3a8a74be862 100644
--- a/app-admin/rex/rex-9999.ebuild
+++ b/app-admin/rex/rex-9999.ebuild
@@ -130,6 +130,12 @@ dzil_src_prep() {
-e '/^\[OptionalFeature/,/^$/d' \
-e '/^\[Test::MinimumVersion\]/{N;d}' \
-i dist.ini || die "Can't patch dist.ini"
+
+ # Removals/additons have to be tracked by git or dzil build fails
+ # Spurious warning during src_prepare
+ git rm -f xt/author/critic-progressive.t || die "Can't rm author/critic-progressive.t"
+ # Spurious warning during src_prepare
+ git rm -f xt/author/perltidy.t || die "Can't rm author/perltidy.t"
}
dzil_env_setup() {
# NextRelease noise :(
@@ -146,7 +152,7 @@ dzil_to_distdir() {
cd "${dzil_root}" || die "Can't enter git workdir '${dzil_root}'";
- dzil_src_prep
+ S="${dzil_root}" dzil_src_prep
dzil_env_setup
dzil_version="$(dzil version)" || die "Error invoking 'dzil version'"