summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-11-19 20:30:54 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2018-11-19 20:30:54 -0800
commite99625554cf9884e38361d73b7da09236ab74b4b (patch)
treedada63aaa2e1b894aff9f2a17fcee146dccc8205 /app-admin/rasdaemon/rasdaemon-0.6.2-r1.ebuild
parentwww-client/chromium: stable channel bump (70.0.3538.110) (diff)
downloadgentoo-e99625554cf9884e38361d73b7da09236ab74b4b.tar.gz
gentoo-e99625554cf9884e38361d73b7da09236ab74b4b.tar.bz2
gentoo-e99625554cf9884e38361d73b7da09236ab74b4b.zip
app-admin/rasdaemon: fix init.d binary paths
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-admin/rasdaemon/rasdaemon-0.6.2-r1.ebuild')
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.2-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.2-r1.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..330e1815fc39
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ dev-db/sqlite
+ sys-apps/dmidecode
+ dev-perl/DBD-SQLite
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ local CONFIG_CHECK="~FUNCTION_TRACER ~FUNCTION_GRAPH_TRACER ~STACK_TRACER ~DYNAMIC_FTRACE"
+ check_extra_config
+}
+
+src_configure() {
+ econf --enable-abrt-report \
+ --enable-aer \
+ --enable-arm \
+ --enable-extlog \
+ --enable-hisi-ns-decode \
+ --enable-mce \
+ --enable-non-standard \
+ --enable-sqlite3 \
+ --localstatedir=/var
+}
+
+src_install() {
+ default
+ systemd_dounit misc/*.service
+
+ newinitd "${FILESDIR}/rasdaemon.openrc" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc" ras-mc-ctl
+}