summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/psmon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/psmon')
-rw-r--r--app-admin/psmon/Manifest1
-rw-r--r--app-admin/psmon/metadata.xml13
-rw-r--r--app-admin/psmon/psmon-1.39-r1.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/psmon/Manifest b/app-admin/psmon/Manifest
new file mode 100644
index 000000000000..992a16bda8c8
--- /dev/null
+++ b/app-admin/psmon/Manifest
@@ -0,0 +1 @@
+DIST psmon-1.39.tar.gz 57475 SHA256 f97d43573473ccfb089d8eca5287151679f378d0e9114f01dd9ba18a28d10ad5 SHA512 08992023af29433da0fe8c48b610df3008b9ea14e197b52bc9582895275fc65cd0faca7e29f36356344219d6a61ef9350713aaa60377ce7ae49a882044b91e32 WHIRLPOOL 3cc5bb554e8919d58ed1dd5a1cdf989d527b917478b550eca77154183dbdcd9d8017c58f9b61f038fafd6b8295fe03939e01fbff2a18b55063a262a8c7979b6f
diff --git a/app-admin/psmon/metadata.xml b/app-admin/psmon/metadata.xml
new file mode 100644
index 000000000000..81ada3d7c6ee
--- /dev/null
+++ b/app-admin/psmon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <longdescription lang="en">
+ A perl script that monitors processes to make sure they are running as
+ the user has intended. Will respawn dead processes and/or kill illegal
+ processes.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/psmon/psmon-1.39-r1.ebuild b/app-admin/psmon/psmon-1.39-r1.ebuild
new file mode 100644
index 000000000000..3d2627cd3f1f
--- /dev/null
+++ b/app-admin/psmon/psmon-1.39-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit perl-app
+
+DESCRIPTION="Monitors process table to slay aggressive, and spawn dead, processes"
+HOMEPAGE="http://www.psmon.com/"
+SRC_URI="http://www.psmon.com/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/Config-General
+ dev-perl/Proc-ProcessTable
+ dev-perl/Unix-Syslog
+ virtual/perl-Getopt-Long"
+
+src_install() {
+ perl-module_src_install
+ insinto /etc
+ doins etc/psmon.conf
+}
+
+pkg_postinst() {
+ einfo "NOTICE: Please modify at least the NotifyEmail parameter found in"
+ einfo "the /etc/psmon.conf file"
+}